This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 5 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
May 31, 2017 at 2:54 pm #1288540

gerritG-2

I am trying to:

hidden link

I expected to see: Save my translated posts happily

Instead, I got:Save or Save&Close Hanging; and rotating disk icons everywhere.

Steps to duplicate the issue:

Please see screenshots

June 1, 2017 at 1:52 am #1288936

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If you refresh the page does the rotating icon remain ?

please test this to rule out any compatibility issues:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

Kind Regards,
Bobby

June 12, 2017 at 5:05 pm #1296573

gerritG-2

Hi There,

The rotating icon is always there and saving always hangs for these posts - wherever there is fixed rotating icon in the lists!!! Regardless of how many times you refresh or login.

Those compatibility suggestions - in our opinion - do not apply since these issues all occur from the administrative WordPress Interface. Also, some other translations don't have these issues and we cannot tell why some are stuck with the rotating icon and some are not...

With Kind Regards,

Dennis

June 12, 2017 at 7:56 pm #1296703

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello ,

I understand that these actions might seem not fitting for your issue but i would like to point out that i have seen a few similar issues that were caused by a compatibility problem.

If possible do let me know if you can perform them and your results with a minimal environment as this will help to rule out specific issues and move forward with debugging the problem.

I would also need to see the detail of your error log.

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

June 19, 2017 at 1:20 pm #1301066

gerritG-2

Hi There, we have added those lines and no file was created after re-creating the hanging after saving.

ls -Rla ~ | grep error_log

yielded no file.

We have tried a Tilda(~) before "/error_log.txt", which also did not help.

We have also uncommented:

//define('WP_DEBUG_LOG', true);

This issue is really annoying since this is a 'production' site.
Maybe it is the best if you login yourself and get the credentials from Konrad/Bernat,

Thanks for your understanding.

Dennis

June 19, 2017 at 7:57 pm #1301388

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

No problem !

If possible it would be best to provide me with the credentials within this support thread.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

June 28, 2017 at 2:30 am #1307111

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I debugged the issue locally using a duplicator package in order to not affect your live site.

Deactivating the plugin "WooCommerce Product Bundles" will allow you to resolve this issue.

You can deactivate the plugin then head to pages or posts and save & close then the spinning wheel will dissapear and everything will save as expected.

Once done you can re enable the plugin if you wish to do so.

I did this and saved the
“Test idworx oPinion BLT multi spec:<br />“Meesterlijk Multitalent”” is locked
Test idworx oPinion BLT multi spec:<br />“Meesterlijk Multitalent” Post from within your posts.

Note : The plugin "WooCommerce Product Bundles" is currently activated . Test this by going to Plugins-> and deactivating it.

NoteII : WooCommerce Product Bundles 5.2.4 http://woocommerce.com/products/product-bundles/ SomewhereWarm is currently not verified as compatible with WPML either

=> https://wpml.org/documentation/plugins-compatibility/

July 9, 2017 at 10:42 am #1315145

gerritG-2

Hi Bobby,

The is a live - production - site, where content is regularly updated in multiple languages. Deactivating plugins is not an option. Could you please fix this in WPML as this is where the issue occurs. We have had this configuration run for over a year now, and never had this WPML saving problem before. Thanks for your understanding.

Dennis (and Gerrit)

July 10, 2017 at 4:51 pm #1316030

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

This is a compatibility issue between WooCommerce Product Bundles and WCML plugins. This issue has been escalated to our compatibility team and they'll further work in accordance with the plugin author in order to resolve this issue.

Once there are news you will be updated here.

Note: For the meantime you can either deactivate the "bunldes" plugin briefly or use the native editor to translate posts/pages (WPML->Translations Management->Multilingual Content Setup-> Create translations manually)

July 12, 2017 at 11:55 am #1317704

gerritG-2

Okay; we have been able to do it manually. Please let us know when WPML works properly again.

Thanks,

Dennis (and Gerrit)

April 30, 2019 at 10:05 pm #3715059

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

This should be fixed in the latest releases of WPML

=> https://wpml.org/downloads/