This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by bastianH-5 1 month, 1 week ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
September 4, 2019 at 2:00 pm #4511673

bastianH-5

I already spoke with my provider that increased the memory limit to 128 MB but it still doesn't work. I installed the needed translation packages and it still sticks in the 2nd step and I cannot choose any language because the "next" button is not clickable.

September 4, 2019 at 2:35 pm #4512101

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

Please try the following steps:

1. Check whether you can find any errors in your browser console.
2. Disable any cache plugins you are using & check again.
3. If there are no changes, then please try to check in a minimal installation by disabling all plugins that are unrelated to WPML and switch to one of the default themes e.g. Twenty Fifteen, Do you see the same issue?

Please let me know how it goes.

Thanks,
Rohan

September 5, 2019 at 7:28 am #4516131

bastianH-5

I am sry, but 1. and 2. didn't work.
The third one I really don't want to try, I am not that well-versed in WordPress and I don't want to smash our website.

Is it possible, that I'll make you an account and you fix this for me?

Best Regards
Bastian Helfrich

September 5, 2019 at 12:53 pm #4519353

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Thanks,
Rohan

September 5, 2019 at 2:26 pm #4520109

bastianH-5

I would need your email to create an account in WordPress.
Please send me the email I can use.

September 6, 2019 at 7:42 am #4523717

bastianH-5

How do I come back to the page where I can send the private information?
Do you strongly need FTP because I don't have access to that, just our provider.

September 6, 2019 at 9:26 am #4524363

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I've enabled the private reply.
You can share the WordPress admin credentials.

Thanks,
Rohan

September 6, 2019 at 7:36 pm #4527203

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for sharing the details.
I am checking your site.
I will update you soon.

Thanks,
Rohan

September 9, 2019 at 7:50 am #4534157

bastianH-5

Hi,

did you find anything?

Best Regards
Bastian Helfrich

September 9, 2019 at 2:05 pm #4537825

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thanks for your patience.

When I checked your wp-admin, there are many browser console errors referring to "jQuery is not defined"(see attached screenshot)

With the "jquery is not defined" error it is a good idea to test in a minimal environment in order to check if another 3rd party plugin is causing this behavior. It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues

I am not able to create a duplicator copy & when I try to disable plugins in your site the server is getting timeout which may also be caused by one of the plugins. So for checking this I recommend using a staging/dev or localhost environment and performing the following test

Minimal Setup
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here: https://pastebin.com/Hg18WN4R for me to see.

Also, I request you to update all the plugins in your site to the latest version.

Thanks,
Rohan

September 16, 2019 at 10:03 am #4578397

bastianH-5

Hello, the problem is solved to get the plugin running.
But we have further problems.

If I want to implement the language switcher, WordPress is sending me the following window you can see in the attachment.

September 16, 2019 at 1:07 pm #4580405

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Since the original issue has been resolved and for better support, we handle one issue per ticket. So may I kindly ask you to close this ticket & open a new ticket for the language switcher issue.

Thanks
Rohan

September 16, 2019 at 1:41 pm #4580869

bastianH-5

My issue is resolved now. Thank you!