Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
With Porto theme I want to use WooCommerce Currency Switcher instead of WooCommerce Multilingual.

Solution:
- Please open your /porto/inc/functions/layout.php file.
- Look for the line172
- Change this:

if ( class_exists('WCML_Multi_Currency') ) {

For:

if ( class_exists('WCML_Multi_Currency') && ! class_exists('WOOCS')) {

0% of people find this useful.

This topic contains 38 replies, has 2 voices.

Last updated by mohammedB-5 1 year, 2 months ago.

Assigned support staff: Andrés.

Author Posts
August 17, 2018 at 9:44 am #2652853

mohammedB-5

Hi Dear,
kindly note that there is a compatibility issue between the woocommerce multilingual and woocommerce currency switcher.
i need to use the plugin of woocommerce currency switcher because it will choose the currency according to the country of the user.
so i do not need the (multi currency) of woocommerce multilingual.

simply, if i activated the woocommerce multilingual then the currency will be shown not correctly.
but if i de-activate the woocommerce multilingual then the currency will be shown Perfectly.

so please check this compatibility issue or delete the (multi currency) from the woocommerce multilingual !!!

see attachements

August 17, 2018 at 2:34 pm #2653469

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

Welcome to WPML support forum.

Your plugin WooCommerce Currency Switcher is not in our compatibility list, however it doesn't necessarily imply that it is not compatible, just that our team has not tested yet.
https://wpml.org/documentation/plugins-compatibility/

1. Could you please update your plugin WooCommerce Currency Switcher to +2.2.5 version?
hidden link

2. If the issue remains, I have created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link you will be automatically logged in.

Please upload your plugin to this test install and setup it the same way as in your website (using the same options). Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

Best regards,
Andrés

August 17, 2018 at 10:23 pm #2654821

mohammedB-5

ok i installed the plugin and activated on the website which you gave me , please check
regarding the update, sorry i do not have account there , i took this copy from my friend

August 18, 2018 at 6:55 am #2655519

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thanks but I can't see the problem with the language switcher on the test site, could you please help me with that?

August 18, 2018 at 7:35 am #2655530

mohammedB-5

i cannot see any product using the existing theme
please this should be ecommerce site so we can check

August 18, 2018 at 1:34 pm #2656068

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I just visited the test site and I can see that you haven't created a product yet. I have created one, but I still can't see the issue with your language switcher:
hidden link

I really need your help as this plugin is not compatible with WPML and I'm not familiar with it, so I don't know the rights settings in order to see what is happening on your site and I can't be of any help.

August 19, 2018 at 9:14 am #2656987

mohammedB-5

Dear ,
this theme not enough , i cannot see the currency switcher ..
please we need to check this using theme

August 19, 2018 at 9:30 am #2656998

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I don't think your theme is needed, that would imply that your plugin is exclusive to your plugin. You need to check your plugin configuration and install it accordingly. If you think you need your theme, please, feel free to install it. This theme is just for your and for test purposes.

Otherwise, we need to change our approach and don't consider this as a compatibility issue but a bug with your plugin and you need to contact your plugin developer.

August 19, 2018 at 9:39 am #2657016

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

For example, at this moment, the currency switcher is available but it does not show any flag with or without WPML, so it seems that your plugin does not allow you this feature.

Could you please check this?

August 19, 2018 at 9:44 am #2657043

mohammedB-5

Please install and check the theme
find the below link
hidden link

i already added the flags please check now

August 19, 2018 at 9:48 am #2657048

mohammedB-5

kindly note that the compatibility problem is in the Currency switcher of the header ... in this theme i am not able to see any currency switcher in the header ..
so please install the theme or any other theme so we can check

August 19, 2018 at 10:06 am #2657058

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I'm not able to download those files, so please, in order to be able to progress install your theme and reproduce the situation that you have on your site. I can't look for another theme for that, that's out of the scope of the support.

I still can't see the flags with your plugin. Otherwise, please contact your plugin developer to help you out and install it correctly.

August 19, 2018 at 10:33 am #2657102

mohammedB-5

Dear
you can check now , its very clear that it is compatibility issue...
see the currency in header , its (US Dollar with euro symbol)
so please we need solution for that , and the problem is not related to that plugin , as you saw that its working perfectly but when we disable the woocommerce multilingual

August 19, 2018 at 10:42 am #2657104

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thanks, so, it means that you also need Porto theme. To be able to continue please upgrade your Porto theme to 4.6.0 version.
hidden link

August 19, 2018 at 10:52 am #2657109

mohammedB-5

done , already updated