Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
With Porto theme I want to use WooCommerce Currency Switcher instead of WooCommerce Multilingual.

Solution:
- Please open your /porto/inc/functions/layout.php file.
- Look for the line172
- Change this:

if ( class_exists('WCML_Multi_Currency') ) {

For:

if ( class_exists('WCML_Multi_Currency') && ! class_exists('WOOCS')) {

0% of people find this useful.

This topic contains 38 replies, has 2 voices.

Last updated by mohammedB-5 1 year, 2 months ago.

Assigned support staff: Andrés.

Author Posts
August 19, 2018 at 11:23 am #2657128

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Great. Now you are using two plugins for the same funcitonnality, the one coming from your plugin (WooCommerce > Currency switcher) and the other coming from WPML (WooCommerce > WooCommerce Multilingual).

As you want to use your plugin currency switcher that is incompatible with WPML, please disable ours and work only with your WooCommerce Currency Switcher or use only our currency switcher as you can't use both at the same time.

August 19, 2018 at 11:25 am #2657165

mohammedB-5

Ok Agree
But i need to translate the products using woocommerce multilingual
that is why i want solution

August 20, 2018 at 6:25 am #2658420

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thanks for helping me to replicate this issue. However, when you go to Appeareance > Theme options > Header > View, Currency Switcher, you can see that the option there displayed read:
- Show WPML Currency Switcher HTML.
This means that this options is made to work with WPML and not WooCommerce Currency Switcher.

On the other hand, why don't you use WooCommerce Multilingual currency switcher instead of using 2 plugins with the same functionality? With this practice you are using more resources, but you are also risking that you users buy your product with the wrong price.

That being said, I strongly recommend you to use WooCommerce Multilingual Language switcher. But if you still want to use your plugin, disable our language switcher and continue using yours. However, this may lead to errors as your theme option was made to work with WPML.

Regards

August 20, 2018 at 9:04 am #2658683

mohammedB-5

Appeareance > Theme options > Header > View, Currency Switcher,,,,,,

Regarding this point , kindly note that this option is working perfectly with WooCommerce Currency Switcher and its not only for WPML , as we can see the flags and the correct prices ...

i am using WooCommerce Currency Switcher because its providing very nice requirement such as Choosing the currency according to the country of the user , and Flags of currency
so i do not need the currency switcher of WPML

Thanks for your recommendation , but as i said this (WooCommerce Currency Switcher is fully compatible with WooCommerce , but WPML not compatible with it , so the problem from WPML ... can you help me !!!!!!????

i hope the issue is very clear now

Regards

August 20, 2018 at 9:13 am #2658692

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I understand the confusion but Porto options reads:

Show WPML Currency Switcher HTML

and not:

Show WooCommerce Currency Switcher

Which clearly means that it is intended for WPML and not your plugin.

I will check with our Compatibility team but I'm afraid the answer will be the same. However, before doing it, I will need you to activate your Language switcher flags as they are not working again with WPML or not.

August 20, 2018 at 9:22 am #2658717

mohammedB-5

Dear
if the WPML not installed , it will be Show WooCommerce Currency Switcher
so this is general currency switcher because its already working with WC currency switcher

the answer will not be the same , until now you are trying to put the responsibility on the other plugins ,,, please if you do not want to support me then forward me to another person from you team

I will need you to activate your Language switcher flags as they are not working again with WPML or not
Kindly explain this ???

August 20, 2018 at 3:36 pm #2660046

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

As I mentioned before, this top bar currency switcher feature from Porto theme is intended to work only for WPML and it shouldn't display any flag. However, if you want to display a flag within, you can create a custom currency switcher.

However, we do see that the top bar language switcher stops working once you activate your WooCommerce Currency Switcher. Despite this is somehow expected (you are using two plugins for the same functionality), I'm waiting for a confirmation to see if it is possible to investigate this other situation.

I will keep you update once I have a confirmation.

August 20, 2018 at 5:53 pm #2660561

mohammedB-5

ok i am waiting your updates
thanks

August 21, 2018 at 10:43 am #2662544

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

After a long discussion, our Compatibility team will check why our Currency switcher stops working under this scenario. However, if you want to add some flags, you will need to customize it.

I will keep you updated of any progress about this situation.

Regards

August 21, 2018 at 12:04 pm #2662852

mohammedB-5

Hi Dear,
this issue is not adding flags
i need to use Woocommerce Currency Switcher and the Woocommerce Multilingual in the same time , i mean i do need to use the (MultiCurrency)

August 21, 2018 at 12:10 pm #2662888

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I will keep you updated of any news.
Regards

August 21, 2018 at 2:15 pm #2663460

mohammedB-5

sorry , i mean i do NOT need to use the (MultiCurrency)
ok i am waiting the update
i hope you can help me in the new ticket which i request

August 21, 2018 at 2:59 pm #2663690

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

That ticket has already been assigned.
Thanks for your comments, I will keep you updated of any news regarding this issue.
Regards

August 23, 2018 at 11:12 am #2669889

mohammedB-5

A Kind Reminder
any solution to disable the multi currency ???

August 23, 2018 at 11:28 am #2669929

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

As it is a compatibility issue it may take a while. On the meantime, you can use our currency switcher instead.

I will keep you updated.