If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
With Porto theme I want to use WooCommerce Currency Switcher instead of WooCommerce Multilingual.

Solution:
- Please open your /porto/inc/functions/layout.php file.
- Look for the line172
- Change this:

if ( class_exists('WCML_Multi_Currency') ) {

For:

if ( class_exists('WCML_Multi_Currency') && ! class_exists('WOOCS')) {

0% of people find this useful.

This topic contains 38 replies, has 2 voices.

Last updated by mohammedB-5 1 year, 2 months ago.

Assigned support staff: Andrés.

Author Posts
August 27, 2018 at 7:27 pm #2679807

mohammedB-5

Hi Dear ,
Please any update ?

thanks

August 28, 2018 at 6:55 am #2680948

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

Nothing solid so far, it may take longer. I will keep you updated.

Regards

August 28, 2018 at 7:00 pm #2683904

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

I just received a feedback from our Compatibility team.

- Please open your /porto/inc/functions/layout.php file.
- Look for the line172
- Change this:

if ( class_exists('WCML_Multi_Currency') ) {

For:

if ( class_exists('WCML_Multi_Currency') && ! class_exists('WOOCS')) {

Does it help?

August 28, 2018 at 8:02 pm #2684084

mohammedB-5

i changed that but unfortunately the problem still exist ,

August 29, 2018 at 6:15 am #2685034

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I just tried on the test site that I shared with you and it is working fine. Could you please:

1. Disable WCML currency switcher in WooCommerce > WooCommerce Multilingual > Multicurrency (add screenshot).

2. Add a screenshot of the file /porto/inc/functions/layout.php file modified.

August 29, 2018 at 7:27 am #2685229

mohammedB-5

Great ! its working , thanks for your support

August 29, 2018 at 7:35 am #2685259

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Awesome! Have a nice day. 🙂

August 29, 2018 at 11:21 am #2686116

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

By the way, do you have Porto author contact details? In that way we can share that code with him and avoid to loosing it after an updated.

Regards

August 29, 2018 at 1:47 pm #2686594

mohammedB-5

this is their support website
hidden link