This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by guentherJ 1 month ago.

Assigned support staff: Bigul.

Author Posts
September 16, 2019 at 10:03 am #4578445

guentherJ

I am trying to:place a Order

Link to a page where the issue can be seen:www.alles-hanf.at

I expected to see:getting a bill in the language that is selected

Instead, I got: a bill in english and German

September 16, 2019 at 6:02 pm #4583081

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps and make sure the issue is existing for not.

1) Visit WPML>>Languages
2) Scroll to *Make themes work multilingual* section
3) Choose *Adjust IDs for multilingual functionality* option and save the changes
4) Scroll to *Language filtering for AJAX operations* section
5) Choose *Store a language cookie to support language filtering for AJAX* option and save the changes
6) Go to WPML>>Theme and plugins localization
7) Choose *Translate themes and plugins using WPML's String Translation only (don't load .mo files)* option for *Localization options*

--
Thanks!

Bigul

September 16, 2019 at 7:32 pm #4583653

guentherJ

step 1-6 i understand, du you mean at step 7 to check this (see pic)

September 17, 2019 at 6:08 am #4585733

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I just made sure you have selected the String Translation option in WPML>>Theme and plugins localization section. Is there any difference in the result after these steps?

If the issue exists, please share me a couple of screenshots(of the bill in English and German) for a better understanding of the issue.

--
Thanks!

Bigul

September 17, 2019 at 3:24 pm #4589633

guentherJ

My issue is resolved now. Thank you!