This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by Alejandro 9 months ago.

Assigned support staff: Alejandro.

Author Posts
December 5, 2018 at 4:58 pm #2970971

boazF

I am trying to:
edit woocomerce shipment using the Hebrew (default) language

Link to a page where the issue can be seen:

hidden link

I expected to see:

Instead, I got: page is messed up
seeing this js error in the browser console:

wc-shipping-zones.min.js?ver=3.5.2:1 Uncaught TypeError: l(...).unblock is not a function
at n.unblock (wc-shipping-zones.min.js?ver=3.5.2:1)

December 7, 2018 at 6:28 pm #2979127

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

By disabling the WPML plugins, does the interface display correctly on the Hebrew?

Also, have you tried disabling all non-WPML plugins for testing? If not, please as a test, could you disable all non-WPML plugins (keep the WPML, WooCommerce, and WooCommerce Multilingual enabled), switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

December 9, 2018 at 7:31 am #2981286

boazF

Hi, by deactivating woocomerce multilingual the problem went way.

December 10, 2018 at 11:59 am #2983928

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

December 11, 2018 at 11:39 am #2988457

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for your credentials. When I try to access the link you posted, an error "403 forbidden" appears. I'll attach an image for you to see.

Maybe your host is blocking external access? Please, could you check?

Thank you.

December 11, 2018 at 12:17 pm #2988556

boazF

please provide your IP so i can whitelist it on the firewall
thanks

December 12, 2018 at 1:05 pm #2993499

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

My IP is dynamic and changes quite frequently. Is it possible, momentarily, to disable the IP filtering feature?

Please, let me know so we can check.

Thank you.

December 12, 2018 at 1:31 pm #2993591

boazF

not really. any other way we can do this ?
im checking with my hosting what can be done

December 12, 2018 at 8:19 pm #2994887

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Maybe you can create a package from your site using the Duplicator plugin (https://wordpress.org/plugins/duplicator/) and send me so I can check if I can replicate the problem in my testing environment?

If yes, please install Duplicator and after creating a copy of your site (files and database), you can host on some server, such as Google Drive or Dropbox and send me the link. Your next answer will be private.

Thank you.

December 17, 2018 at 5:10 pm #3009628

boazF

i disabled wordfence. can you try again please ?

December 24, 2018 at 12:38 pm #3030499

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Please, my sincere apologies for the delay in answering. Unfortunately, I have not been able to see your message before. The message displayed is still the same as it was before. You may have already activated the wordfence plugin again.

Please, could you deactivate it one more time to test?

Thank you.

December 25, 2018 at 7:17 am #3031930

boazF

Hi, what if give you cpanel access ? would that work ?

December 26, 2018 at 12:27 pm #3034011

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Just with cPanel, I will not have how to see what is happening on your site. The problem does not appear to be database-related.

After doing some testing, I noticed that I can replicate the problem in my testing environment. Is the Shipping page displayed in English or Hebrew?

If even with the backend language being Hebrew the Shipping page is being displayed in English, this may be causing the problem. Please follow the steps below:

- Click on the Dashboard > Update
- Make sure your translations are up-to-date
- Click on the WPML > Theme and plugins localization
- Select the "Don't use String Translation to translate themes and plugins" option
- Click on the Save button
- Click on the WooCommerce > Settings > Shipping. The problem persists?
- If the page is loading correctly, click on the WPML > Theme and plugins localization
- Select the "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" again
- Click on the Save button
- Check again

If the problem persists after following these steps, we'll need to check directly on your site. You can create either a test environment where the problem is replicated so that we can test or create a package from your site using Duplicator plugin so that I can download and test it in my testing environment.

Thank you.

December 27, 2018 at 12:18 pm #3036810

boazF

Hi Bruno
problem persists
sorry.
i mean you can use cpanel to export the files to your environment
ok ?

December 27, 2018 at 12:50 pm #3036875

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sure. I think it's worth the test. Just let me know the credentials properly and if you have more than one site installed on the server, please let me know which one is in trouble so I can export the correct site.

Your next answer will be private.

Thank you.

The topic ‘[Closed] woocomerce shipment admin panel js error when switching to Hebrew’ is closed to new replies.