This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 18, 2019 at 9:27 am #4042071

javier-zapataz-2

Hi,

When using Woocommerce and WPML with tour theme, this result in a WPML error:

«We detected that the product_type field was set incorrectly for some product translations. This happened because the product_type taxonomy was translated. You can fix this in the WooCommerce Multilingual troubleshooting page.»

What I found the solution :

This line should be removed:
<taxonomy translate=”1″>product_type</taxonomy> in the wpml-config.wml file.

My Question :

If I update this plugin I think again this XML file will updated automatically.

So please suggest.

Thanks,

June 18, 2019 at 8:47 pm #4046441

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

if that happens you could always go to WPML->Settings->Custom XML Configuration and add the following

<wpml-config>
    <taxonomies>
        <taxonomy translate="0">product_type</taxonomy>
    </taxonomies>
</wpml-config> 

let me know your results please

June 19, 2019 at 6:24 pm #4053951

javier-zapataz-2

I did not update the xml from the text editor. Error is showing there "wpml-tm-custom-xml-editor.js?ver=2.8.6.1:104 Uncaught ReferenceError: vkbeautify is not defined"

June 19, 2019 at 6:37 pm #4054015

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please go to your plugins , deactivate WPML main plugin and WPML translation management

and download the latest versions from here https://wpml.org/downloads/ then re install them

this should resolve this issue. There are some libraries missing as you can see in the console error but it should be resolved with a fresh re install of the plugins WPML and Translation Management

let me know your results please

The topic ‘[Closed] Woocommerce and WPML: error’ is closed to new replies.