This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 18, 2018 at 1:14 pm

rasmus hoeks

If i go to a product page, eg. this one: hidden link and click on an attribute, i go to a page with products with the same attribute.

If I go to the danish version of the same product: hidden link and click on an attribute, i don't get any products.

This is the same with all product attribute pages. They are available in english, but bot in danish.

I have attached screenshots of the english and the danish view of the attribute page

______

As I can't create a duplicator package, i have created an Akeeba package. The backup and kickstart file is posted as the duplicator package. NB. The wp_uploads folder is not included, as it is very big.

September 19, 2018 at 1:41 pm #2748961

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Please be sure to make a full backup of your site and database.

Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Have you translated all of your products to the secondary language? Also, please go to WooCommerce -> WooCommerce Multilingual and click the Attributes tab. Here, select each attribute and click synchronize attributes and update product variations. Does this resolve the issue?

It not, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Now do the products display in secondary language?

September 24, 2018 at 1:47 pm #2760655

rasmus hoeks

I did all of the things, and it helped me out with som other problems regarding WPML but not this issue.

The products are translated, and the attributes are connected. Some attributes exist, and are not connected, but these are not the ones in question.

September 24, 2018 at 3:09 pm #2760872

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This may be happening due to your custom permalink structure. I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. Then, go to Settings -> Permalinks and switch to default or postname permalinks. With these settings, does the product(s) display correctly on the attribute page?

September 26, 2018 at 6:47 am #2766028

rasmus hoeks

Hi again.

I have now done everything you have asked for, in the latest response as well. Still the same issue.

I deactivated all plugins but woocommerce and wpml related plugins.
I changed the theme to Twenty Seventeen
I updated everything

I still have the same problem. The only difference here, is the error message saying something in line of "No products matching your selections was found"

September 26, 2018 at 2:34 pm #2767701

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. I made a copy of your site to test locally, and was able to reproduce the issue. I have escalated this to our 2nd Tier Support team. I will be working with the developers to find a resolution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.

September 28, 2018 at 8:13 am #2772837

rasmus hoeks

Thank you for that, hopefully we can find a solution for this, as it is needed on the site.

September 28, 2018 at 1:46 pm #2774099

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I can understand how it is needed on your site, and I will update here just as soon as I have more information. I appreciate your patience while we continue troubleshooting.

October 2, 2018 at 3:07 pm #2781999

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please go to WooCommerce -> WooCommerce Multilingual and disable "Show only products with custom prices in secondary currencies" . After this, the products should show in your secondary language. If you need to use the option to only show products with custom prices, then you will just need to add the price in the secondary currencies for all products.

Please let me know if you need any further assistance and I will be happy to help.