This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Itamar 1 month, 1 week ago.

Assigned support staff: Itamar.

Author Posts
September 6, 2019 at 12:21 pm

janM-14

I am trying to: translate woo attributes using Multilingual

Link to a page where the issue can be seen: eg. hidden link (additional information tab)

I expected to see: translated attributes: not "POJEMNOŚĆ" but "CAPACITY"

Instead, I got: attributes in polish not in english

September 8, 2019 at 12:53 pm #4531457

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the issue on your site at the link that you have shared with me.

I couldn't log into your site to check the issue. I've received the following error.

ERROR: The username or password you entered is incorrect.

In any case, please confirm that you are following our documentation here.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/
Please note this section about translating attributes.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/#taxonomies
And if your attributes are custom product attributes that are used for variations, please see this section on how to translate them.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-product-variations

If you want to share with me the access to the site, please correct the details in the original private message.

Thanks,
Itamar.

September 8, 2019 at 6:09 pm #4532307

janM-14

Hi,

WP admin credentials are ok, just url is different. Correct one is: hidden link

BR,
Jan

September 9, 2019 at 8:11 pm #4540045

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Jan.

Thanks for the correct access details. I've checked things on your site and found that the attributes' label was written in Polish but assigned to the English language. Please see the attached screenshot. So I've changed this. But unfortunately, it didn't help. Please proceed with the following.

I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentynineteen and no plugins activated except WPML. You will need first to check if the problem persists when just the theme is switched to Twentynineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself (without any of its extensions). Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

September 10, 2019 at 10:59 am #4544365

janM-14

Hi,

I've done everything you wrote but issue still exists even on default theme and with all plugins switched off

September 10, 2019 at 8:35 pm #4548819

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

Can you please go to the troubleshooting section of WooCommerce Multilingual and try the following.

1. Take a backup of the DB if your site

2. Go here hidden link

3. Press the following options.
- Sync products "gallery images"
- Sync products categories (display type, thumbnail)
- Fix translated variations relationships

Does it help to solve the issue?

Regards,
Itamar.

September 10, 2019 at 8:37 pm #4548821

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Please take a backup of the DB of your site before following the above.

The topic ‘[Closed] woocommerce attributes don't translate’ is closed to new replies.