Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Yvette 2 weeks, 1 day ago.

Assigned support staff: Yvette.

Author Posts
November 14, 2019 at 5:44 pm

handeG

hidden link
hidden link

Hello there. There is a problem. I did not understand what happened. attributes seemed before. does not appear anymore. all attributes translations completed. not missing.

The additional information tab does not appear. turkish tried to edit the product. this is not possible. fixes on english page.

November 18, 2019 at 8:41 am #4962875

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I visited the product links you provided.

For me, I am seeing the Turkish Additional Info tab and inside, I can see a list of attributes.

1. Is this still an issue for you? Did you already resolve the problem?
2. If not, what are the precise attributes that are not appearing anymore?

3 Can you confirm that the English product is completely correct on the frontend?

THanks

November 18, 2019 at 12:56 pm #4965331

handeG

Hello there. At first I thought you were getting better. I import products with wp all import. When I press update on the English page of the product appears.
The product has English and Turkish pages. Additional information is available on all products.

hidden link
hidden link

please check?

November 18, 2019 at 2:29 pm #4965809

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I can see that there are a number of untranslated attributes that may be affecting the success of importing products and their attirubutes.

For WPML ALl Import to work, all taxonomies must be fully translated before attempting to import the translated products.

In your particular example product, there were 3 attributes that were not translated. Once I complted the translation, then the information showed in the translated product.

November 19, 2019 at 8:01 am #4969125

handeG

Turkish and English products can not be given different attributes? need not be the same.

November 19, 2019 at 8:13 am #4969317

handeG

should always appear.

November 19, 2019 at 11:09 am #4971237

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Products in different languages can normally have different attribute VALUES (they are translations) but normally they are expected to have the same attributes. This is espeically true for attributes that are used in pricing (e.g. product variations)

Nevertheless, it is possible to have different attributes appear as long as you maintain the mutlingual content settings to be "Do not translate" : WPML > Settings > Taxonomy Translations

I am unclear how this impacts the import process overall. I just know that for the example product, the taxonomy terms were not translated and this blocked the attributes from appearing on the Additional Info tab.

November 19, 2019 at 11:18 am #4971383

handeG

There is a problem here. the problem is solved when I manually update the product. that does not need to be translated. previously, each language had different attributes. then the same attributes should appear. I need to be able to add different attributes to each language.

November 19, 2019 at 11:32 am #4971447

handeG

hidden link

look. English product page appears when I press update. I didn't make any other changes. There is something that doesn't work here. I think the price is the same with the subject.

https://wpml.org/forums/topic/set-prices-in-other-currencies-manually-not-working/

I can't enter every product and update. English and Turkish I need to add different features.

November 20, 2019 at 9:15 am #4977977

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

1. You wrote: "..the problem is solved when I manually update the product. that does not need to be translated..."

Yes, this is because on updating the original language product, the attributes that are set to "copy" are synce. In your example, you had attributes that were set to "Translate" but the *term* did not exist in the target language.

If your attributes are NOT set to "copy" or "translate" then there should be no issues on having different attributes in each language. In other words, those particular attributes should have the multilingual options set to "Do not translate".

2. Your product:
hidden link

I visited this product and it did not turn into English. Did you mean the frontend or the backend? I also tried the dashboard/backend and nothing turned into English..all text remained in Turkish.

I am obviously missing something here. PLEASE UPLOAD SCREENSHOTS or a screencast so that I can understand what you are referring to and move more quickly to a resolution.

3. Updating your products
You can use bulk update to do a quick updates to your products

3.1. Switch to the source language of your products
3.2. Go to Products > All Products
3.3. For each page, select all products by checking the top box of the listing (see image)
3.4. Scroll to bottom of the screen in the "Bulk Actions" section select "Edit" and then the button "Apply"
3.5. Then select "Update" in the resulting screen

This should trigger a sync of all taxonomies and custom fields to translated products. You should do same with the target language products as well just to be sure.

The alternative is to remove the products you imported, fix all translations of your attributes previous to attempting to import, then try the import again.

November 20, 2019 at 10:22 am #4978597

handeG

I have completed all translations. There is a problem here. why does not appear. I didn't understand what you said in the previous message. If the problem is corrected when I press the update, there is a problem here.

Can you check?

problem persists. shared screenshot.

November 20, 2019 at 10:28 am #4978671

handeG

I don't want some attributes to appear for each language. I want it to appear in some. for this I need to enter different attributes for each language. there was no lock before.

I could add 2 different features for 2 different languages before.

November 20, 2019 at 1:19 pm #4980553

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Please upload a screenshot of what you are talking about. This is the best way to move forward as I can only guess what you are referring to.

November 20, 2019 at 3:23 pm #4981591

handeG

Although I have completed all translations, the 2nd language does not appear.

November 20, 2019 at 3:25 pm #4981709

handeG

your login information is available. You can check. I'm adding a language converter to the bottom of the products.

The topic ‘[Closed] Woocommerce attributes not show’ is closed to new replies.