Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 2 years, 9 months ago.

Assigned support staff: Bigul.

Author Posts
February 13, 2018 at 4:03 pm

Mayer

George Botsev suggested that I open a new ticket.

I am trying to see translated attributes here (EN):
hidden link
originally present here (HU):
hidden link

I did the table fixing with the help of George. (sent him the dump and duplicator and sent me back the update SQL-s.)

I did AFTER THE DB UPDATE:
-recreted the attributes
-translated the atributes
-Clicked sync attributes

Still the attributes do not show up in the English product

This was working earlier, now it does not work in ANY products.
eg.
HU: hidden link
EN: hidden link

February 15, 2018 at 12:08 pm #1518909

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mayer,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you sync the Product variations from WooCommerce>>WooCommerce Multilinugal>>Status>>Trouble shooting? Because now the Troubleshoot screen is showing *Sync products variations: 3 left* message. Please check the attached image for more details.

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

Please share me the previous ticket URL for a better understanding.

--
Thanks!

Bigul

February 15, 2018 at 7:18 pm #1519576

Mayer

Hi Bigul,

I did these steps, no luck.
To make sure you understand what I did, I'll write down the steps:
I did the troubleshooting page. See the result in an attached image.
I did disable all the plugins, (Only WPML and WOO plugins remained ON)
See the result of the same product I sent the link to before in the second attached image.

The previous ticket was this:
https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/

G

February 16, 2018 at 11:10 am #1520129

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mayer,

Thank you for the updates. Please let me know the following for tracking the issue.

1) Create a Test Product with variations, then translate it to English and check the variation is showing in the frontend or not

2) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] Woocommerce attributes not showing’ is closed to new replies.