This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 3 voices.

Last updated by Jamal 4 months, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
March 28, 2019 at 4:28 pm #3483893

francescoR-28

I am trying to:

Using this plugin that allow us to have a B2B area in woocommerce:
hidden link

Link to a page where the issue can be seen:
Whole website.

I expected to see:
When a user registers to the website he needs to be approved, and he get an email where the website says he needs to be approved by an administrator. Then, when an admin approves the new user, the plugin WooCommerce B2B send another email to the user, saying he is now approved and can login to the website.

Instead, I got:
The 2nd email is in the default website language and not in the user language.

March 29, 2019 at 3:26 pm #3492635

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I was not able to find that plugin being part of our official WPML-compatible plugins directory here:
https://wpml.org/documentation/plugins-compatibility/

However, that doesn't mean that the plugin is not compatible 100% but there might be incompatibilities happening.

1. Can you please let me know if there is a place in the backend where you set the message in the emails that the users receive? It would be very helpful if you can tell me how I can get in that place where you add/edit the text in the emails if there's anything like that. Or does the text come automatically and you can't edit it?

2. Can you please attach some screenshots with the email text that you are referring to?

3. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 1, 2019 at 1:36 pm #3508507

francescoR-28

Hello.
We are still waiting for a reply.
We can't go online with this bug. The plugin support is always available and they tried to add a patch in their plugin with your documentation i send to them, but is not working.

Thank you in advance.

April 1, 2019 at 6:47 pm #3510981

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sorry for the late reply but unfortunately I don't work on the weekends.

I was trying to log into the site using the credentials that you shared with me but they don't work (I am attaching a screenshot, too).

Can you please check and re-add the credentials that work under my reply here?

I am activating the private fields once again.

I will be waiting for your reply.

Kind regards,
Mihai

April 3, 2019 at 2:24 pm #3527081

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information you attached.

I can also confirm that the credentials are valid this time.

Before we go any further, there are multiple updates that we just launched (hidden link).

Can you please create a backup of your current site, update the plugins and then try to see if the issue is still happening?

Updating everything to the latest version might not solve anything but we need to make sure this condition is met and that the strings are properly translated in WPML String Translation.

Please let me know if anything changes after you follow these steps.

From what I can see, strings are translated as you said and they are coming from the .mo translation file - that is why it has that yellow background (I attached a screenshot for that).

If nothing changes by following the steps above, can you please let me know what happens if you try to add the same phrase from the screenshot I attached ("Il tuo account è stato approvato ed è ora abilitato all’acquisto.") right in the field below, check "Usa la mia traduzione" and click "Salva".

Please let me know if that changes anything.

If, again, nothing happens, can you please confirm that in order to test (and receive that email), it would be enough to just create a new user on your site with my email)?

I will be waiting for your response.

Kind regards,
Mihai

April 3, 2019 at 2:52 pm #3527551

francescoR-28

Hello.
I updated everything and nothing changed. I don't need to tell WPML to "use my translation" because is using ONLY the translation. As i said the first email is sent in english, but the second is always sent in italian, i actually have no way to receive the approvation email in english.

For testing you can just create a new user with your email, as you said. Then you need to approve the user from the user management section in wp-admin.

Thank you in advance.

April 3, 2019 at 4:59 pm #3529069

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the confirmation.

I will spend some time on this and I will get back to you as soon as I have any more feedback.

I will leave the ticket assigned to me for the moment.

Kind regards,
Mihai

April 5, 2019 at 2:42 pm #3545083

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I spent a good amount of time on multiple test cases but it seems that it still sends the second email in Italian, no matter what I try.

From what I can see, the developers say that together with the plugin, it also comes some documentation.

1. Can you please send me the documentation? I will activate a private link where you can share a google drive or dropbox link with the documentation

2. I was not able to find any other place where you could at least change the default strings (like the default phrases in English and Italian for the second email - do you know if something like that is available somewhere in the backend? I have seen that the only B2B settings page is under WooCommerce > Settings > B2B

3. Taking into consideration that this plugin is not part of our official WPML-compatible plugins directory, there are high chances that the plugin is at the moment, not 100% compatible with WPML - even if, from what I have seen in their presentation, they say their plugin is compatible with WPML (that might be however partially) and even if the strings show up in WPML > String Translation.

Maybe I will be able to figure things out from the documentation I asked you to share at point 1 but just in case that won't be possible (and there are high chances, taking into consideration that there is less to none information online about their plugin and the translation process), I will create a clean-install sandbox test environment on our servers and I will need you to reproduce the same issue there so that I can forward this to our Compatibility department (that's why I will need the issue reproduced on a clean install - meaning that we will use only the minimum required plugins like WPML + WooCommerce + B2B plugin and a default WP theme - but if it works with a default wp theme, please try to do the same with the theme that you are using, so install your theme, too if that's needed - you might need to install the SMTP plugin in case the emails don't work).

Here is the sandbox I created for you:
hidden link (one-click login)

Feel free to set up WPML and WooCommerce exactly as you want and as you have it set up on your site.

I will be waiting for your response so that we can go forward with the debugging process.

I decided to give you the sandbox now rather than just waiting for the documentation and try to see if I can understand something from that first, just for wasting as less time as possible.

Just a note that I won't be working on the weekend so I will be able to get back to you on Monday if you can respond this weekend.

I am waiting for your response with interest so that we can get this debugged further as soon as possible.

Have an amazing weekend (I wish I was able to solve this TODAY so that you could have an even better weekend but unfortunately that was not possible).

Kind regards,
Mihai

April 8, 2019 at 9:24 am #3555947

francescoR-28

Hello.
In your demo sandbox is a little more bugged than mine, because when i create the user i don't have any message that says i have succesfully created my account and i need admin approva. This happens in my website.

By the way now everything is running and the confirmation email is still beign sent in italian.

Thank you in advance.

April 8, 2019 at 10:17 am #3556483

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My colleague Mihai is not working today, i'll take care of this ticket right now.
In fact our sandbox is limitting emails as it could rapidly turn to a spam weapon. So i installed the WP Mail Logging plugin which will catch any plugin and log it. See attached image of where you can check emails.

If you can also provide steps on how to approve the user! So i can reproduce this error on my own.
I'll remain at your disposal.

Best regards,
Jamal

April 8, 2019 at 10:19 am #3556493

francescoR-28

Hello.
I attached our SMTP mailer to send emails.
Steps to approve users are simple. Go to edit the user you want, there is a "status" or "stato" section with a dropdown menu when you can choose is the user is active or not.

April 8, 2019 at 12:28 pm #3557651

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I run a couple of tests and from what i could gather. The activation email is sent with the administrator's language.
I activated a user from another administrator(wpml) with english as admin language, and the email was sent in English.

As a workaround you will need to create another administrator user for each language in your website and assign him the proper language in Users->Profile. Then use it to activate the user for the proper customer.

I will summarize the issue and escalate it to our compatibility team for further checking. And i will get back to you as soon as possible.

Best regards,
Jamal

April 8, 2019 at 3:25 pm #3559737

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

The ticket is now escalated to our compatibility team. Please note that it may take a while depending on their priorities. Use the workaround suggested in the meantime.
I will get back to you as soon as we have any news from the compatibility team.

Best regards,
Jamal

April 8, 2019 at 3:33 pm #3559805

francescoR-28

Hello and thank you for the reply.
Please, keep in mind that if you need you can contact the plugin's author.

I'll wait any news from the compatiblity team.
Thank you in advance.

April 9, 2019 at 8:02 am #3563951

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I escalated the author information to the compatibility team, they will contact the author and work with him to make the plugin compatible.
I will let you know any progress about it.

Best regards,
Jamal

The topic ‘[Closed] WooCommerce B2B – Activation email is sent in the default language’ is closed to new replies.