This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.66 hours from now. Thank you for your understanding.

Author Posts
April 12, 2019 at 11:11 am #3597955

noelR

Hi, sorry for my bad english but i need help with this problem.

Original product: hidden link

Calendar work without problem.

Translated: hidden link

Calendar: Not working.

I tried activated "Ajax..." in settings but the problem continue.

I seen this: https://wpml.org/forums/topic/woocommerce-bookings-calendar-not-displaying-bookings-properly-in-translated-con/

"Set "block_cost" to "copy" in WPML > settings > Custom field translation and you will avoid this."

But the problem continue.

April 12, 2019 at 6:44 pm #3601265

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @noelr, welcome to the WPML support Forum!

Please try the following:
- Go to the edit screen of the product
- Scroll down to "Multilingual Content Setup"
- Check if the "Set "block_cost" field is set as copy. if not, fix it and lcick on apply
- Do a small modification on the content and save. This step is important to update the product settings
- Update and save the translation as well.

Please let me know if it worked for you.

All the best,
Diego

April 13, 2019 at 11:53 am #3604429

noelR

Creo que habla español por su perfil así que mejor se lo explico así.

En el producto español no me aparece el block cost y en el inglés tampoco. Me aparecen esos y en el inglés no me deja poner la opción de traducir, ni copiar ni nada.

También le he agregado las imágenes de como tengo los costes puestos y como aparecen en la traducción (que no me deja modificar en la traducción).

April 15, 2019 at 5:10 pm #3615239

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Envié algunas instrucciones para replicar el sitio web a través de un mensaje privado (respuesta anterior).

Por favor digame si funcionó para ti. Si es así, envíenos instrucciones claras sobre cómo ver / reproducir el problema.

Saludos cordiales,
Diego

April 15, 2019 at 8:03 pm #3616269

noelR

Las instrucciones que me facilitó no funcionaron correctamente.

He creado una copia exacta del sitio original donde puede modificar todo lo necesario para probar ya que no afectará al sitio original.

[content removed]

April 16, 2019 at 7:16 pm #3625027

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Muchas gracias. hidden link

He traducido el producto al inglés en el sitio de pruebas, pero el calendario no se carga. Esto aparentemente está ocurriendo debido a un error de javascript en la consola.

Voy a seguir investigando y te envío una respuesta en breve.

Saludos cordiales,
Diego

April 16, 2019 at 9:45 pm #3625777

noelR

Si necesita acceso vía ftp puedes pedírmelo.

Un saludo.

April 17, 2019 at 6:51 pm #3634355

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I disabled the following plugins on the test install (see screenshot) and the calendar worked on the test site. So I enabled the plugins again one by one and it seems that the issue is being caused by the "All 404 Redirect to Homepage" plugin. If you just disable it, the JS error does not occur anymore and the booking calendar is loaded. You can check on this link: hidden link

Could you please check if it also works on the original website?

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Kind regards,
Diego

April 17, 2019 at 10:12 pm #3634943

noelR

De acuerdo, muchísimas gracias 😀

Una duda, ¿te ha tardado bastante en cargar? Con WooCommerce Multilingual se ralentiza muchísimo. (En ocasiones tarda hasta +10 segundos)

April 18, 2019 at 8:36 pm #3641805

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hola,

Sí, pero su sitio web tiene una gran cantidad de plugins activos, lo que requiere más recursos de la CPU.

Aquí hay algunos consejos sobre cómo puede mejorar algunos puntos:
- Compruebe si su servidor cumple con los requisitos mínimos de WPML / WordPress
WPML: https://wpml.org/home/minimum-requirements/
WordPress: https://wordpress.org/about/requirements/

Lea este artículo para ver cómo optimizar su sitio web con WPML: https://wpml.org/2012/01/can-your-site-run-faster/

Verifique los dominios registrados automáticamente en WPML> Traducción de cadenas y asegúrese de que todos los dominios estén incluidos.

Además, deshabilita las siguientes configuraciones:
- Ajustar ID para funcionalidad multilingüe (WPML> Idiomas)
- Seguimiento de dónde aparecen las cadenas (WPML> Traducción de cadenas)

Como el problema de este ticket ha sido resuelto, voy a cerrar este ticket. Si necesitas más ayuda, por favor abre un nuevo ticket, estamos a disposición.

Saludos cordiales,
Diego