This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 3, 2018 at 3:53 pm #1535172

marcW-29

I am trying to: We're using woocommerce bookings to sell products. We do have some problems with the localization of the whole thing. One is that we receive multiple cancellation emails when a customer cancels a booking (one for every language)

Obviously we expect at only receive 1 cancellation email if a customer cancels 1 booking.

II researched quite a bit in this forum and it seems there have been similar issues regarding this for other mails like reminders. We know that internally wpml creates a booking for every language and this might cause the problem but we don't know how to solve it.

Hope you can help

March 5, 2018 at 5:39 pm #1536705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

March 6, 2018 at 2:07 pm #1537715

marcW-29

Hello,
We increased Memory as suggested and also tried to deacivate all plugins except the WPML Plugins and Woocommerce (plus woocommerce bookings).

We still have the same problem. Cancellation mails are sent twice: one with the english booking ID and one with the german booking ID

best

March 6, 2018 at 4:33 pm #1537929

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

Thank you very much for your feedback.

Could you provide a download link with a copy of the site? This way I can make further tests without affecting the live site.

I recommend you to use the Duplicator plugins and don't include the media library and cache folders and they aren't needed for testing purposes. Also, please don't forget to share the installer.php file too.

I have set your next answer private which means only you and me will have access to the information, there you will find the correspondent field for the download link.

Looking forward to your answer.
Kind regards,
Carlos

March 8, 2018 at 6:31 pm #1541018

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

It seems that you forgot to attacha the download link to your previous answer. Could you please edit your previous answer and add the link?

Regards,
Carlos

March 8, 2018 at 10:15 pm #1541245

marcW-29

Hi Carlos,

that's weird, I'm pretty sure I added the link. However now the field for the link is greyed out even if i tick the checkbox. It just won't let me use the textbox.

Could you set the next message to private once more?

Thanks for your help

March 9, 2018 at 5:27 am #1541368

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

I have set your next answer private.

Regards,
Carlos

March 12, 2018 at 1:51 am #1542998

marcW-29

Hi Carlos,

Sorry for the late response, but now I'm asked for all served details. Is it possible to just send you the link somehow?
Unfortunately the first private message won't let me do this. I just can't enter anything in the box where the link should got. Not in chrome and not in safari.

Best regards,

March 12, 2018 at 4:38 pm #1543849

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

I have set your next answer private again. Please check if there isn't any browser addon that may be blocking the private answer.

Looking forward to your answer.
Regards,
Carlos

March 12, 2018 at 7:15 pm #1543999

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

Yes it worked this time 🙂

I will forward the details to our Themes & Plugins Compatibility Team and they will contact the author.

Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author asking him to reply us. This may help expedite the process.

Thank you very muhc for your understanding!
Kind regards,
Carlos

August 9, 2018 at 2:14 pm #2629203

Jol Ebrahim

Hello, i have the same problem... do you resolve it?

this is a screenshot from my email, i recibe one emar per language or more...

hidden link

Thanks

August 21, 2019 at 11:46 am #4430927

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marc,

Could you confirm that this issue was solved in the latest version of the plugin?

Regards,
Carlos

August 21, 2019 at 11:46 am #4430929

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi @jol Ebrahim

Could you confirm that the issue is solved in the latest version of the plugin?

Regards,
Carlos