This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.19 hours from now. Thank you for your understanding.

This topic contains 26 replies, has 2 voices.

Last updated by Bigul 12 months ago.

Assigned support staff: Bigul.

Author Posts
September 18, 2018 at 8:24 am #2744003

maxP-8

Hello,

I have a few products live on my website now, using woocommerce bookings. When translating the Person Typesm, cause some products need those. Then the products result into being non bookable. The error message "Number of persons is needed" keeps showing up. Bookig the product in the original language does work as expected. You can see it here:
hidden link (original, working)
hidden link (translated, not working)
Can you please check and help me with the issue? I've already tried to delete the person types and added them again, but no luck unfortunately. Also, when I am logged in it also works, but with my partner it doesn't.

Thanks for letting me know what to do!

Best regards
Raymond

September 19, 2018 at 8:23 am #2747784

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

If you are still having the issues, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

September 19, 2018 at 3:33 pm #2749321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for the login information. Please grant me access to the Plugins directories. Because I would like try after deactivating other plugins and with the default theme(2017).

Also please note, I am not able to access FTP because of the following error. Please check.

Status:	Waiting to retry...
Status:	Connecting to **********:****...
Response:	fzSftp started, protocol_version=8
Command:	open "****@************" ****
Error:	Network error: Connection refused
Error:	Could not connect to server

--
Thanks!

Bigul

September 20, 2018 at 5:08 pm #2752877

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for the updates. I can log in to the FTP and access Plugin directory now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

September 21, 2018 at 4:06 pm #2755917

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Sorry, I am again having the privileges issue. Now not able to access the WordPress Dashboard. The result is the same after several tries. Please check the attached images for more details.

Please grant me full Admin privileges for further cross-checking.

--
Thanks!

Bigul

September 24, 2018 at 4:51 pm #2761340

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for the updated login information. I can log in to the site now. It looks like the issue is happening because of compatibility conflict with Pro theme. It works fine when the theme is 2017. Please check the attached images for more details.

One issue now. I have deactivated and activated the plugins as a part of the testing. But now the issue is existing for the default language also. Maybe some settings are changed. Please check and let me know your feedback.

Also, I have a request. Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 25, 2018 at 2:19 pm #2764211

maxP-8

Hi Bigul,

It is an compability issue with the theme. I have tested it myself, I even went away from the child theme and the same problem ocured. In the original language (German) all works fine on my end.

Yes ofcourse you can use the plugin to duplicate the website.

One question, are you in contact with Apex (Themeco) yourself?

BR
Raymond

September 26, 2018 at 5:59 am #2765980

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for the updates and permission. I made a Duplicator copy of the site. We haven't contacted the Apex(Themeco) yet. We have to complete the escalation process before that.

I will try to trace the issue with your Duplicator package and also in a fresh installation. Please wait.

--
Thanks!

Bigul

September 27, 2018 at 7:32 am #2769492

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

For your kind updates, somehow the Duplicator package is not working as expected. It is taking too much time for responding. Please check the attached image. Therefore I will try to reproduce the issue in a fresh installation as a part of our escalation process and get back to you soon. Please wait.

--
Thanks!

Bigul

September 27, 2018 at 7:36 am #2769531

maxP-8

OK

September 27, 2018 at 6:12 pm #2771511

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

For your kind updates, I am not able to reproduce the issue in a fresh installation exactly. Therefore I have tried to install Duplicator again, but the result was same. So I am trying to configure the site manually, but the database is taking more than expected time for import.

Is it possible to test on staging site again, because I can see a few changes on the site? If possible please create a test product on Staging site and check the issue is existing or not. Now I am not able to test it exactly on staging site because of the date change. Sorry for the delays.

--
Thanks!

Bigul

September 28, 2018 at 6:51 am #2772704

maxP-8

Hi Bogul,

Yes I have activated all the other plug-ins as on the main site as I was troubleshooting something else as well. THe issue between WPML and PRO has been isolated and I thought it not to be a problem. You can do whatever you want on the staging site as we can make a new copy at any time. That is what it is for 🙂

Also, test product is not needed because I can still see the issue for the month October. But to make it more easy for testing, I made all days available for booking. I can only reproduce this for translated (no German) versions of the product.

Let me know if you need anything else

BR

September 28, 2018 at 7:09 pm #2774727

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for the updates. I am still having issues to configure the site on my local server and unable to replicate it in a fresh installation.

Therefore I had a few tests in your staging site. But sorry, now I am not able to access the WordPress Dashboard after I network deactivate of Dokan plugins. Therefore please restore the site. After restoring the site back up I will share the details with our second tier for the expert opinion.

--
Thanks!

Bigul

September 29, 2018 at 9:22 am #2775489

maxP-8

Hi Bigul,

No problem. I deactivated and reactivated all the plugins and now you can get back in.

Thanks for helping and keeping me posted on the progress!

BR
Raymond

October 1, 2018 at 9:43 am #2777608

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Raymond,

Thank you for restoring the site. I have forwarded the details to our second tier team for the expert opinion and waiting for their feedback now. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul