This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Woocommerce Categories not picking up Images for new languages

Solution:This is happening because if you go to WPML->Settings->Custom Term Meta Translation -> thumbnail_id is set to "Dont Translate". Instead it needs to be set to "copy"

also it is recommended to translate the category terms from WooCommerce>>WooCommerce Multilingual>>Categories because of the easy sync to the secondary language.

You can also translate the Term from Product categories screen, but you have to manually upload the Image file. Because we have to enter all the values in the edit screen fields.

The best way to resolve this issue since you have already added the translations to French is to go to WooCommerce>>WooCommerce Multilingual>>Categories and click on "Copy to all languages" this will overwrite the current translations of your categories and copy the media to all your languages

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by seand-4 3 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
July 5, 2019 at 12:26 pm

seand-4

I am trying to: Create French site - all done but most of the Category images in woocommerce have not come across?

Link to a page where the issue can be seen:
hidden link
hidden link
Most Categories are the same

You probably need a user and password to get onto our test site :

user = client
password = headred

I expected to see: All images updated automatically.

Instead, I got: Missing Images....

July 6, 2019 at 12:55 am #4154207

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

when i go to FR product-categories i can see that a few are showing a media

after examining them i can see here that there is no media added to the Thumbnail

hidden link

please let me know your results if you edit it and add a media

July 8, 2019 at 8:47 am #4160207

seand-4

Hi - do they need to be added manually for each Category for each language? I assumed this would be picked up automatically from the default UK category they were created from?

July 8, 2019 at 6:25 pm #4165029

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

This is happening because if you go to WPML->Settings->Custom Term Meta Translation -> thumbnail_id is set to "Dont Translate". Instead it needs to be set to "copy"

also it is recommended to translate the category terms from WooCommerce>>WooCommerce Multilingual>>Categories because of the easy sync to the secondary language.

You can also translate the Term from Product categories screen, but you have to manually upload the Image file. Because we have to enter all the values in the edit screen fields.

The best way to resolve this issue since you have already added the translations to French is to go to WooCommerce>>WooCommerce Multilingual>>Categories and click on "Copy to all languages" this will overwrite the current translations of your categories and copy the media to all your languages

let me know your results please i have test this and it works as expected

July 9, 2019 at 11:16 am #4170069

seand-4

Hi Bobby,

I can;t see this option? Can you screen shot where you think it should be (or login and have a look)

The best way to resolve this issue since you have already added the translations to French is to go to WooCommerce>>WooCommerce Multilingual>>Categories and click on "Copy to all languages" this will overwrite the current translations of your categories and copy the media to all your languages

Thanks,
Richard

July 9, 2019 at 5:57 pm #4173645

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

please review the following screencast

=> hidden link

July 10, 2019 at 9:57 am #4177955

seand-4

My issue is resolved now. Thank you!