This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When browsing the shop in the primary language there's no issue. When browsing it in a secundary language all of the WooCommerce category pages are not working. They return the error: this page cannot be found .

Solution: Once you changed the slug for the product category base in each language (through Dashboard → WPML → Settings), go to Dashboard → WPML → String translation, search for the category base in default language, and mark all the translation as complete. Also, don't forget to save the permalinks.

This topic contains 14 replies, has 2 voices.

Last updated by Radu 1 month, 1 week ago.

Assigned support staff: Radu.

Author Posts
September 4, 2019 at 9:19 pm

jaapd-2

Hi,

I have an urgent issue with one of my customer webshops. When browsing the shop in the primary language there's no issue. When browsing it in a secundary language all of the WooCommerce category pages are not working. They return the error: this page cannot be found (in Dutch).

webshop: hidden link
Example url: hidden link

I've checked the translations and they are correct. I've also saved the permalinks again. Products are working fine.

I'm running the latest versions of WPML plugins.

Please help.

The webshop is running on a lifetime WPML license (not mine) and is a production server.

Cheers,
Jaap

September 5, 2019 at 4:51 am #4515437

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

Thank you for reaching out the WPML support!

I just found the original category for Men Jeans right here hidden link and when I try to use the language switcher from the top of the page, I'm taken to this page hidden link which works fine as well.

Can you check this out and tell me if it works for you too, please?

Thanks,
Radu

September 5, 2019 at 5:05 am #4515485

jaapd-2

Hi, you’re right DE is working but NL is not. Can you try NL?

September 6, 2019 at 7:15 am #4523577

jaapd-2

Hello, can this problem looked into promptly? This is a big issue since it's a production server.

September 6, 2019 at 8:42 am #4524119

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

I was checking this out but I can no longer see the NL option in the language switcher. Can you tell me if you recently set the NL language to hidden, please?
Also, can you tell me how did you ad the language switcher to the top of the page? I am trying to check all the settings to make sure that I'm not missing anything.

Thanks,
Radu

September 6, 2019 at 9:26 am #4524365

jaapd-2

Hi,

I have disabled NL since it is not working and visitors need to be able to buy. I don’t know how the switcher has been adder. Nor relevant for this issue I think? You can enable NL to test and look into the issue.

September 6, 2019 at 10:36 am #4524849

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

I know that tests on a live website, where users have access too, is not a good idea so there's something else we can try. Please create a duplicator package as presented here https://wpml.org/faq/provide-supporters-copy-site/ and give me a message back once the package is generated. This way, I'll be able to download it from your website and create a local copy of your website on my computer (and test anything I need, without having to make the NL language on your website yet.

Thanks,
Radu

September 6, 2019 at 12:40 pm #4525341

jaapd-2

Hi,

The website and db are too large to create a duplicate with duplicator. It's ok to look at this problem on the live server. You can enable Dutch language to look into the problem.

September 9, 2019 at 12:07 pm #4537009

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

Can you check now the NL category and tell me if it works as expected, please? You said that this pretty important since it's in production website so I tried to focus on sorting this out.

Thanks,
Radu

September 9, 2019 at 12:09 pm #4537041

jaapd-2

Hi Radu,

I still get page cannot be found. For example:

hidden link

Cheers,
Jaap

September 9, 2019 at 12:28 pm #4537097

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

Can you try the link again, please? I just checked it right now and it works on my side.

Thanks,
Radu

September 9, 2019 at 12:35 pm #4537117

jaapd-2

Hi Radu,

It works! Did you change something? I only disabled Elementor Pro. But I also enabled it again and the problem still is gone. Very strange so I hope you changed something.

Cheers,
Jaap

September 9, 2019 at 2:09 pm #4537887

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

I didn't make any special change. I just saved again the permalinks and that's all 🙂

Regards,
Radu

September 9, 2019 at 2:26 pm #4537985

jaapd-2

Strange, i've done that a couple of times. anyway, it's working now so the ticket can be closed.

September 9, 2019 at 3:22 pm #4538509

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jaap,

I'm glad to hear that everything works fine now. Don't forget that you can open a new ticket any time you need some help with some other issue or maybe with just a quick question.

Regards,
Radu