This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 1 year, 2 months ago.

Assigned support staff: Itamar.

Author Posts
March 13, 2019 at 12:28 pm


I am trying to: Import translated products through WP All Import

Link to a page where the issue can be seen: hidden link

I expected to see: All categories translated

Instead, I got: Only first category in hierarchy is translated to English, others are newly created and on default language (Croatian)

I've entered everything correctly in WP All Import and can't seem to find where is the issue.
Import was canceled just to show few products for an example.

March 13, 2019 at 1:32 pm
March 13, 2019 at 2:06 pm #3334265


Good news guys! I've found what I was doing wrong! When testing all the options for taxonomies in WP All import I haven't check this little box here in the attachment. Sorry for bothering you and thanks for all the help! Must say, you gave me excellent support!

March 13, 2019 at 2:29 pm #3334657


Well only one minor issue with this one... In hierarchy I have categories with same name but different slug, one is parent and second one is child category and when I use that WP All Import options I've mentioned above it ignores the second category... How can this be resolved? I need them both.

March 14, 2019 at 4:32 pm #3347175


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great! I'm glad that you have found the cause of this issue.

For the minor issue, please see this from our documentation.

Terms should not have the exact same name in the original and translated languages, otherwise, the import of the translated terms will not function properly. If terms have the same name in multiple languages, it is recommended that you change the name of the terms in the translated terms before import. After successful import, you could change the name of the translated term to be the same as the original term.

In short, you cannot have the same name for taxonomy and its translation while importing them.


March 18, 2019 at 9:49 am #3367507


They are all translated off course but some of them had (before I've renamed them) the same name. Let me explain it in this way:

(1.) Socks
— (1.1) Men's socks
— — (1.1.1) Men's knee socks
— — (1.1.2) Only men’s socks (this was called "Men's socks" like the one above - 1.1 - but it had a diferent slug)

The issue was when I imported them in EN language, import process ignored the second taxonomy (1.1.2 - the one with the same name, see above). Didn't think that there would be a problem because it had a different slug. First, I renamed them without slug in English to "Only men's socks" and it didn't work. So I've also renamed them in default language, Croatian, from "Muške čarape" to "Samo muške čarape" with new slug and runned the import again and it still doesn't work. This also happens on "Women's sock", I only have two taxonomies with the same name... Could you take a look insid a WP or something, or this is a common issue and I'm doing something wrong 🙁

March 19, 2019 at 2:41 pm #3380221


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


The problem that I've mentioned is when you have the same category name in the original import and the import of the translation. The name is the issue and not the slug. You describe here a situation where there is the same name for a parent and grandchild category in the same language.
Is this correct?
If so then it is different, and I'm not sure what happens in this situation.

When I look in WooCommerce -> WooCommerce Multilingual -> Categories (tab), I can see that the translation for the category is there. It seems to n=be translated alright. Please see the attached screenshot only-man.jpg. So if I understand, correctly the issue is that no English products with the category of 'Only men's socks' were imported.
Is this correct?
If so, then did you remember to change the category in each of the imported English products?

If this is not the issue and the English products were imported but only not showing here:
hidden link
then you might want to try the troubleshooting section.

Please try the following.

1. Take a backup of the DataBase of your site.

2. Go to WooCommerce -> WooCommerce Multilingual -> Settings and press the 'Troubleshooting' link (bottom right corner).

3. On the troubleshooting screen, please press the 'Sync products categories (display type, thumbnail):' button and wait for the process to finish.

4. If you are using cache on your site clear the cache and check if the issue is solved.

5. If it isn't solved please go to WPML -> Support -> Troubleshooting (link).

6. On the troubleshooting screen, please press the following buttons.
- Select 'Products' and press the 'Synchronize posts taxonomies' button.
- Set language information
- Translatable taxonomies linking. For 'product_ca' select Product Categories if not selected already.

Other then this, I've also looked at the files that you imported. In the Taxonomies, Categories, Tags tab I can see a different setting. Maybe this is where the problem is?
For Coratioan please see screenshot Hrvatski.jpg
For English please see screenshot English.jpg

Please let me know if this information is helpful to you.


The topic ‘[Closed] Woocommerce category taxonomy not translating correctly’ is closed to new replies.