This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 1 month ago.

Assigned support staff: Bigul.

Author Posts
September 4, 2019 at 4:15 pm

jeroenS-7

I am trying to translate category names, but somehow there are no categories showing up in the page where you would expect category translation to be;
WooCommerce Multilingual > Categories (which even shows the mark that not all categories are translated). When I select "Show all categories" or "untranslated Product categories", both don't show anything. On the right side it tells me that there are 12 items which should appear in the list, but in no way i get to see them. Hierarchy synch, also empty on that page.

When I go to translate Attributes (which also have the sign that there are items not yet translated) also the list remains empty in every way. There is no way I manage to solve it.

I expected to see:
Product categories in original language.

Instead, I got:
nothing. See attached image.

September 4, 2019 at 5:50 pm #4513365

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

It is happening for other taxonomies also like Post Categories and Tages in WPML>>Taxonomy Translation section. So please share with me the WordPress debug.log (not WPML debug information) for tracking the issue.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

September 5, 2019 at 10:23 am #4518397

jeroenS-7

Hi Bigul,

Thanks for your answer and trying to solve this with me. I added the debug settings to wp-config and re-checked all possible options to translate the categories and attributes. Still no result in being able to translate them, but also the debug.log remained empty, except for another plugin which was causing some non-relevant warnings.

That got me thinking and I tried a different approach. Since the system is telling me that there are 12 items, but non are showing up, it reminded me of another issue we had long time ago with another plugin and -if I remember correct- not even WPML involved. Somehow WordPress in combination with something about user rights (which I have to figure out yet), is causing the categories not to show up. Maybe because they were imported from csv-file with WP-ALL-IMPORT, not sure about that.
But once I add new categories to Woocommerce, tags or attributes, WPML is noticing those without problem and I'm able to translate those without any problems. So I have to figure out which is causing the conflict there, and not why WMPL is not able to translate.

If you have a suggestion where to look next, you would be my here, because I have no clue where to look to solve this. But at least I know where to start looking to find the solution.

Thanks again for wanting to help me out.

September 5, 2019 at 5:40 pm #4521139

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for details. Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

If the issue exists, please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 9, 2019 at 1:06 pm
September 9, 2019 at 5:18 pm #4539283

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for updates. This may be happening because of the Cache issues. Please click on *Check for Updates* button of the Plugins>>Add New>>Commercial Tab to refresh and make sure you are getting the expected result in the Plugin lists of Commercial tab.

Have you changed the Password? I am not able to login to the site now. Please check.

--
Thanks!

Bigul

September 10, 2019 at 8:06 am #4542839
jeroenS-7

Thanks! That worked and now showing all new versions. All released yesterday, that makes sense than.

By checking for updates, WordPress gave some technical issue, recorded in the error.log. I also noted some other errors with WPML and JetEngine combination, so I've made a pastbin for you to see if anything strange is happening:
https://pastebin.com/7Qf5yg3U

Last two lines are the errors after hitting the "check for updates" button. Not quite sure why, perhaps runtime error or something, maybe of interest to know. And it would be perfect if you could take a look into the attributes translations with the java error appearing in the Chrome console.

Thanks!

September 10, 2019 at 6:10 pm #4547999

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have opened a new ticket for the New Issues. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new tickets. Please wait. Thank you for your understanding.

--
Thanks!

Bigul