Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by albaC 1 year ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
September 30, 2019 at 11:29 am

albaC

Hi,

I've alredy transated the fields of the checkout manager in the string translation and is not working. It was working until the last two weeks maybe.

Can you please help me?

Thanks,

September 30, 2019 at 12:07 pm #4664491

Rohan Sadanandan

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Could you please try these steps & let me know the results:

- Navigate to WPML > Theme and plugins localization > Strings in the plugins > Select "WooCommerce Checkout Manager" & click on "Scan selected plugins for strings" & wait for the confirmation that it is completed.
- Once it is completed navigate to WPML > String Translation & check for the strings.

Thanks,
Rohan

September 30, 2019 at 3:19 pm #4665927

albaC

Hi!

I have already found and translated the strings. The problem is that the translations done don't appear. Thanks!

October 1, 2019 at 10:27 am #4671015

Rohan Sadanandan

Hello,

Could you please try to re-save the string:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sorts of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards. You can also disable the cache plugin temporary while you update this string.

4. If the issue still persists, I request you to share a screenshot of the page marking the section which is not translated.

Thanks,
Rohan

October 3, 2019 at 12:07 pm #4687357

albaC

We have followed these steps and the problem still remains. Take into account that some time ago it worked perfect. See the image attached. I have indicated the fields affected by this problem. Thanks!

October 3, 2019 at 4:48 pm #4689897

Rohan Sadanandan

Hello,

Thank you for sharing the screens.

For further checking, I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Thanks,
Rohan

October 3, 2019 at 4:48 pm #4689899

Rohan Sadanandan

Hello,

Thank you for sharing the screens.

For further checking, I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Thanks,
Rohan

October 7, 2019 at 8:07 am
October 7, 2019 at 8:16 pm #4710725

Rohan Sadanandan

Hello,

Thank you for sharing the details.
I'm checking your site.
I'll update you soon.

Thanks,
Rohan

October 8, 2019 at 12:54 pm
October 10, 2019 at 9:01 am #4728553

albaC

The migration is done. Thanks!

October 10, 2019 at 8:55 pm #4734041

Rohan Sadanandan

Hello,

Thanks for completing the migration.

I just checked & found that the fields & labels are created in the Woocommerce Checkout Manager interface(hidden link). So it is not translated from the String Translation section.
I switched the language on the admin top bar & saved the string but the same string is showing in all the languages. I doubt this is a compatibility issue with the plugin. I've asked for expert opinion from our 2nd tier support team. I will update you once I get feedback from the team.

Thanks,
Rohan

October 11, 2019 at 1:02 pm #4738483

Rohan Sadanandan

Hello,

Thank you for your patience.

Please navigate to WPML > Settings > Custom XML configuration & paste the below code in the textarea & click on save. Once it is saved please navigate to WPML > String Translation & you will be able to find the strings.

<wpml-config>
  <admin-texts>
    <key name="wccs_settings">
      <key name="buttons">
        <key name="0">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="1">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
      </key>
    </key>
    <key name="wccs_settings2">
      <key name="shipping_buttons">
        <key name="0">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="1">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="2">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="3">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="4">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="5">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="6">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="7">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
      </key>
    </key>
    <key name="wccs_settings3">
      <key name="billing_buttons">
        <key name="0">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="1">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="2">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="3">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="4">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="5">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="6">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="7">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="9">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
        <key name="10">
          <key name="label"/>
          <key name="placeholder"/>
        </key>
      </key>
    </key>
    <key name="wc_fields_additional">
      <key name="order_comments">
        <key name="label"/>
        <key name="placeholder"/>
      </key>
      <key name="additional_">
        <key name="label"/>
        <key name="placeholder"/>
        <key name="options"/>
      </key>
    </key>
  </admin-texts>
</wpml-config>

Please let me know if you have any doubts.

Thanks,
Rohan

October 18, 2019 at 2:07 pm #4783153

albaC

Finally solved! Thanks!