This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 1 year, 1 month ago.

Assigned support staff: Itamar.

Author Posts
September 19, 2018 at 12:31 pm #2748741

Rein

Hello,

I'm having a problem with WPML and product bundles.
My site is originally english and has a dutch translation beside it. On the english site everything is working fine. But on the Dutch part customers can't check out. When going to the shopping card you get the message error content is missing from the shopping cart. This only happens with the bundles products on normal product it's working.

Hope someone can help me.

Kind Regards,
Rein

September 20, 2018 at 8:36 am #2751451

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rein.

Please confirm that you have the problem with this plugin and that you are using its latest version. https://woocommerce.com/products/product-bundles/

I would like to ask you to try the following, please.
By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 64M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this is OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this is OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help?

Thanks,
Itamar.

September 20, 2018 at 9:03 am #2751544

Rein

Hi Itamar,

Thanks for your reply. I can confirm that i'm using the official bundles plugin from woocommerce and is up to date. So is the rest of the site.

I've changed the memory limit to 256m but this haven't solved the problem yet.

Kind Regards,
Rein

September 20, 2018 at 10:54 am #2751778

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Rein, thanks for trying my suggestions.

I would like you to try another thing, please.
I suspect that there is a collision with the theme or another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists then turn off all plugins except WPML and its add-ons, WooCommerce, and the Product Bundles plugin.
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back. Then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

The topic ‘[Closed] Woocommerce checkout not working with Product Bundles translation’ is closed to new replies.