This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.14 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 2 months, 4 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 16, 2019 at 2:48 pm #4221329

maciejK-15

Hi guys,
I created custom email in woocommerce for completed orders.
In wpml>theme and plugins localization I've searched for the new strings within woocommerce domain.
Strings in body, header and subject have been located and translated.
After selecting language on the website and going thru the booking process, confirmation email has a correct translation of email's body, but subject and header always comes up in Polish(my default wordpress language).
Also I don't know if issue is related, but in woocommerce>settings>email, after i type in header and subject in with polish languge selector under fields and hit save, everything works as expected,
but If change dropdown menu and input header and subject of email in english and hit save nothing is saved and website comes up with dropdown menu in polish and field unchanged.
Thank you for your help regards

July 17, 2019 at 3:45 am #4225693

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

July 22, 2019 at 3:36 am #4253689

maciejK-15

Hi Dennis,
My issue isn't resolved yet.
I wonder if you could provide me with information on how to resolve this issue on my own.
I have sensitive information on my wordpress installation, few databases and I would prefer to provide you with administration account as a last resort.
Please let me know, if there's some pointers you could provide me to troubleshoot the problem
Kind regards

July 22, 2019 at 8:59 am #4255073

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

To debug the issue further, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced.

More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

-Try to reproduce the issue.
-Locate the debug log in: /wp-content/debug.log using FTP, then edit/view the content of the file.

Do you see any php errors related to WPML? Could you please share the debug.log content to us? You can use https://pastebin.com/ so you can just share the link to us.

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then:

-go to WPML > String Translation
-try to search for the strings again in WPML > String Translation and translate them completely.

To check for a possible theme and plugin conflict. Please follow these steps:

-backup your site completely.
-deactivate all non-WPML plugins, except the plugins required to debug.
-switch to a WordPress default like Twenty Sixteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Please let me know your results.

Kind regards,
Dennis

The topic ‘[Closed] Woocommerce Completed order email’ is closed to new replies.