Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by juanC-38 2 years, 7 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 7, 2019 at 4:00 am #3973887

batmunkhB

When change WPML currency is normal. But after order is made, it remains to default currency (USD), not change to MNT (Mongolian) currency. also email was sent customers by not changing currency.

Please see image
This image is showed by not changed currency when order is confirmed.

Please help me to resolve this woocommerce currency issue.

Thank you

currency.JPG
June 7, 2019 at 5:08 am #3974067

batmunkhB

Please see image below
hidden link

I think Mongolian currency is still USD

June 7, 2019 at 11:20 am #3975821

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have tested your site and I can reproduce the issue.
Can you please share temporary access to your site so that I can check a few parameters, I have enabled private fields for you to securely share the details.

Kind regards
Raja

June 7, 2019 at 3:39 pm #3977501

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This seems more like a compatibility issue or any of the plugins is interacting or conflicting with WPML.

It seems like you have a couple of other WooCommerce plugin related to payment and other services. Please disable other WooCommerce plugins except for the WooCommerce and WooCommerce Multilingual, Check if the issue can be reproduced.

Please share with me the results. If the problem still persists. I would request you to share a snapshot copy of your site You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/. I have enabled the private fields for you to securely share the details with us.

Kind regards
Raja

June 8, 2019 at 4:25 am #3980467

batmunkhB

Hello,
1. Few days ago i was changed WPML - Languages - Language switcher options - English Mongolian to Mongolian English. Otherwise replaced English Mongolian to Mongolian English.
So MNT currency was doubled price in MNT or USD. So i was changed back it.
Please see below images.

2. When made a order by MNT currency, There is double or maybe triple price in MNT. Please see images. Please see woocommerce - orders
3. I also changed woocommerce - settings - General - Currency options from USD to MNT. and i was changed back it
Please see images

Thank you

currency MNT 3.JPG
currency MNT 2.JPG
woocommerce currency.JPG
June 8, 2019 at 4:31 am #3980543

batmunkhB

I think main reason is changed WPML - Languages - Language switcher options - English Mongolian to Mongolian English.

June 8, 2019 at 4:37 am #3980545

batmunkhB

i was setup currency exchange rate by theme settings - booking options.

Maybe this was related?

Please see images

currency MNT 4.JPG
June 8, 2019 at 4:38 am #3980569

batmunkhB

Please also check Woocommerce - woocommerce Multilingua - Multi-currency

Thank you

June 8, 2019 at 4:42 am #3980573

batmunkhB

if necessary, please fix the issues by WP admin without my permissions.

June 10, 2019 at 4:03 am #3985095

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the information about current settings in the Theme options,
I have checked your settings in detail I can see you have enabled Multicurrency option in WooCoommerce > WooCommerce Multilingual > Multi-Currency However, the settings have only USD as the currency option which is the reason your orders default to USD.

Please add the secondary (MNT) currency in WooCoommerce > WooCommerce Multilingual > Multi-Currency, Apply the same exchange rates.

If bookings are treated as WooCommerce pages then you can remove the multicurrency option from the theme and use the WooCommere Multilingual Multicurrency option.

Please let me know the results.

Kind regards
Raja

June 10, 2019 at 6:22 am #3985295

batmunkhB

Hello,
Thank you for your advise. i have done according to your advise . it is working
But There is another issue.
When make a order, there is a difference between total price and subtotal price only by email.
Please see images

Please help me to resolve this issue.

Thank you

total payment.JPG
total payment. 2JPG.JPG
June 10, 2019 at 9:01 am #3986009

batmunkhB

Please see woocommerce - orders. MNT Price is doubled or tripled

Please see image

check payment.JPG
June 10, 2019 at 12:13 pm #3987329

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This might be due to cache issue try clearing the cache in your site.

I see the exchange rate for the MNT is different than in the Multi-Currency settings, Maybe to try removing the currency option in the theme settings and let the WooCommerce Multilingual handle the currency settings. check if that helps.

Kind regards
Raja

Screenshot 2019-06-10 at 5.39.08 PM.png
June 11, 2019 at 1:56 am #3990945

batmunkhB

1. I have cleared cache in my site and browser.
2. I set exchange rate for the MNT is same with the Multi-Currency settings, but price is doubled.
3. When i removed the currency option in the theme settings, but seeing no price at all.

Please see images
Please help me
Thank you

USD.JPG
MNT.JPG
June 11, 2019 at 2:14 am #3991087

batmunkhB

When sending order by email, total price is a different than in the subtotal.
Please also see woocommerce - orders - there is doubled price in orders.

Thank you