Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 2 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 20, 2020 at 11:58 am

marcelD-22

I deactivated all. But even with just Woocommerce and WPML Multilangual CMS active, the information on the WooCommerce dashboard doesn't display. But when I deactivate the WPML plugin, it works again.

March 20, 2020 at 1:17 pm
March 20, 2020 at 2:45 pm #5728773

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The browser console is showing JavaScript error while having this issue. All the URLs are pointing to the hidden link. Please check the attached images for more details.

Have you imported the site recently from the localhost? If so, please check hidden link URLs are still existing in the database.

--
Thanks!

Bigul

2020-03-20_2009.png
2020-03-20_2010.png
March 20, 2020 at 2:49 pm #5728867

marcelD-22

Yes correct. It's also one of the things I mentioned to your colleague. I have never moved the site from localhost to live. I built it online. I'll check in the database for localhost values.

March 20, 2020 at 2:59 pm #5728901

marcelD-22

I have just checked the database. There are no references to localhost. Also after the check it's still showing the same errors and no information (infinite loading)

March 20, 2020 at 4:29 pm #5729449

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please try the following steps after a full site backup and check is there any difference in the result.

1) Deactivate and delete WooComemrce and WPML plugins from the plugin directory
2) Visit Settings>>Permalinks and resave the settings
3) Download the latest version of WooComemrce and WPML
4) Clear all types of caches
5) Upload the activate WooCommerce
6) Visit Settings>>Permalinks and resave the settings
7) Upload the activate WPML

--
Thanks!

Bigul

March 22, 2020 at 9:15 am #5735251

marcelD-22

Hello Bigul,

I have followed your steps. But without result. The same issue is still there.

March 22, 2020 at 9:25 am #5735259

marcelD-22

The debug.log only shows these lines for every time I reload the dashboard page:

[22-Mar-2020 09:21:12 UTC] get_cart was called incorrectly. Get cart should not be called before the wp_loaded action. Backtrace: require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WCML_Currencies_Payment_Gateways->init_gateways, WCML_Currencies_Payment_Gateways->get_available_payment_gateways, WC_Payment_Gateways->get_available_payment_gateways, apply_filters('woocommerce_available_payment_gateways'), WP_Hook->apply_filters, eCurring_WC_Plugin::eCurringFilterGateways, WC_Cart->get_cart, wc_doing_it_wrong. This message was added in version 2.3.
[22-Mar-2020 09:21:12 UTC] get_cart was called incorrectly. Get cart should not be called before the wp_loaded action. Backtrace: require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WCML_Currencies_Payment_Gateways->init_gateways, WCML_Currencies_Payment_Gateways->get_available_payment_gateways, WC_Payment_Gateways->get_available_payment_gateways, apply_filters('woocommerce_available_payment_gateways'), WP_Hook->apply_filters, eCurring_WC_Plugin::eCurringFilterGateways, WC_Cart->get_cart, WC_Cart_Session->get_cart_from_session, do_action('woocommerce_cart_loaded_from_session'), WP_Hook->do_action, WP_Hook->apply_filters, WC_Cart_Session->set_session, WC_Cart_Session->get_cart_for_session, WC_Cart->get_cart, wc_doing_it_wrong. This message was added in version 2.3.

One odd thing I noticed is that the dashboard, customers and other pages don't show any database informaiton. But when I go to WooCommerce > Reports, it does display some information that also would need to be at the dashboard page.

Yes, the top still displays a not loading message.

Screenshot 2020-03-22 at 10.24.37.png
March 23, 2020 at 5:12 am #5738061

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share with me the correct Login URL to access the site backend now.

Also, please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

March 24, 2020 at 2:11 pm
March 25, 2020 at 7:13 am #5757401

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I am not able to reproduce the issue on my local copy. Also, the WooCommerce>>Reports page is loading fine for me on your site & my local copy. Please check the attached images for more details.

Therefore I will consult with our second-tier team for the expert opinion and get back to you soon. Please wait.

--
Thanks!

Bigul

2020-03-25_1237_001.png
2020-03-25_1237.png
2020-03-25_1236.png
March 26, 2020 at 3:00 pm #5770893

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

This is happening because of a compatibility conflict with your server. We are getting the expected result on your site after the following change. Please check now.

1) Go to *wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy* folder
2) Open *class-wpml-url-converter-domain-strategy.php* for edit
3) Scroll down to line 47
4) Made the following change

From

$url_parts['host'] = $_SERVER['SERVER_NAME'];

To

$url_parts['host'] = $_SERVER['HTTP_HOST'];

The issue is escalated to our developers for fixing. We will get back to you soon when we have an update on this from our developers. Please wait.

--
Thanks!

Bigul

August 2, 2021 at 8:32 am #9325693

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We are closing this ticket now. The bug is fixed in the latest version of WPML. Please upgrade to the latest version after a full site backup{mandatory} and make sure the issue is existing or not.

If you still have similar issues, please feel free to open a new ticket. We are happy to help always. Thank you for your understanding.

--
Thanks!

Bigul

The topic ‘[Closed] Woocommerce Dashboard not display information for me’ is closed to new replies.