This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Yvette 1 year, 5 months ago.

Assigned support staff: Yvette.

Author Posts
May 10, 2018 at 4:33 pm #2077144

MANUELA GIORGETTI

Tell us what you are trying to do?
I update all plugin of Wpml and Woocommerce discount but i receive this error: (see attach image)
Then i try to deactivate the woocommerce discount plugin and the site is ok, but if i switch on wpml and woocommerce discount there is a conflict

What is the link to your site?
hidden link

May 11, 2018 at 11:55 am #2088058

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Indeed, I do not find this plugin included in the list of certified and tested extensions for Woocommerce:
https://wpml.org/documentation/plugins-compatibility/

This can be that it is not compatible with WPML.

Can you confirm that this is the plugin you are using?
https://wordpress.org/plugins/woo-advanced-discounts/

If not and it is a payed plugin, I would need to have a zip copy of the plugin to install in our local servers and test. I am opening the private area for this . Please use a filesharing platform to upload the plugin zip and just include a downloadable link to the platform location.

You should be informed that the time to make a plugin compatible with WPML can be long and depends entirely on the complexity of the integration work as well as the availability and willingness of the plugin author to work with our team.

In the meantime, please also send us informaiton about your installation as instructed here:
http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

May 15, 2018 at 5:18 pm #2145270

MANUELA GIORGETTI

Hi thanks for your answer. All discount plugin is a payed plugin version
Below the link for download the all discount plugin:

hidden link
I hope in your answer
Thanks

Manuela

May 15, 2018 at 6:52 pm #2146399

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thank you for the plugin. I installed it on my local WPML / Woocommerce test server but did not get the same result. No message was given when it was activated.

So I cannot confirm any compatibility problem between WPML and this plugin.

1. Please also send us information about your installation as instructed here:
http://wpml.org/faq/provide-debug-information-faster-support/

2. Diagnostics
2.1 Test 1
- Temporarily deactivate all non-WPML plugins
- Temporarily change your active theme to Twenty Seventeen

Do you still get the system message?

Thanks for letting me know the resutls

May 16, 2018 at 10:17 am #2154533

MANUELA GIORGETTI

Hi for testing i have disable the all discount plugin and so the error isn't show
Below the diagnostics information:

thanks

May 16, 2018 at 10:20 am #2154689

MANUELA GIORGETTI

This is the debug information

May 16, 2018 at 10:42 am #2155159

MANUELA GIORGETTI

Hi, sorry but i have another error with wpml in the general panel when for example i select an option, then i clic save. The system save but the changes isn't correctly applyed.
For example if i select hide the language selector english for visitors ... i receive ok for save control but if i refresh page, the change has not been registered .
In taxonomy for example i have two attribute that i need to translate but it isn't show 🙁

i attach a screenschot

May 16, 2018 at 4:12 pm #2161010

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I think my request was not clear. Please put the following plugins in this state:

- Woocommerce discount plugin . ACTIVATED
- Woocommerce ACTIVATED
- Woocommerce Multilingual ACTIVATED
- WPML CMS ACTIVATED
- WPML Media ACTIVATED
- WPML Translation Management . ACTIVATED
- WPML String Translation ACTIVATED
- all other plugins DEACTIVATED

1. Now, with your normal theme enabled: Are you able to activate the plugin without receiving errors?

2. If you still receive errors, then change you active theme to Twenty Seventeen : Are you able to activate the plugin without receiving errors?

Please let me know the results in your next reply.

With regards to your other issue, please open a new ticket on the forum for this. We ask clients to only place one issue per forum thread to expedite escalation to the right resource if required.

Thanks

The topic ‘[Closed] Woocommerce Discount not compatible with WPML’ is closed to new replies.