This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 24, 2018 at 6:24 pm

albertoD-25

Hello,

If you go to my homepage in English and click on a product this appears in Italian, I can not understand why. The product is translated.

Thank you

September 26, 2018 at 12:49 am #2765407

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. This looks like it's happening for some caching system. It looks like the URL is not preserving the secondary language parameter and so it displays the page in Italian (default language).

Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

September 26, 2018 at 6:55 am #2766066

albertoD-25

Yes! Of Course.

September 26, 2018 at 1:11 pm #2767377

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, Bruno is off for a few days so I am stepping in to help out. I hope that is okay.

Let's test a few things to see if we can isolate where this issue is coming from. First, please go to Settings -> Permalinks and switch to default or postname permalink structure. Save your changes and clear your browser cache. Now do you get directed to the English product?

If not, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WooCommerce and WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

September 26, 2018 at 4:02 pm
September 26, 2018 at 11:35 pm #2768861

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending me the duplicator files. I was able to set up a snapshot of your site locally. I deactivated all non WPML plugins and switched to a default theme and the page redirected correctly. I then reactivated your theme and the plugins one at a time and found that the conflict is coming from the Permalink Manager plugin.

I see that this plugin is not listed on our compatible plugins list: https://wpml.org/documentation/plugins-compatibility/

We can suggest the plugin's author to join our Go Global Program (https://wpml.org/documentation/theme-compatibility/go-global-program/). You can either contact them directly or provide us their contact details (name + email) so we can get in touch with him.

September 27, 2018 at 7:40 am #2769591

albertoD-25

Hello,

I prefer you contact them, so you understand better. Thank you.
hidden link

September 27, 2018 at 1:54 pm #2770779

albertoD-25

I solved the language problem by contacting the plugin developer, but every now and then I get a 500 error, I made a video, look: hidden link

The author of the plugin says it's not his plugin's fault, I think it's WPML, can you help me solve it?

September 27, 2018 at 2:43 pm #2770896

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Do you get the error when you deactivate Permalink Manager?

Our Compatibility team will need to get in touch with the plugin author so that they can work together to find a resolution. Please send me a copy of the plugin so that I can test this on a fresh install and once I am able to reproduce, I can send this information to our compatibility team. I have marked the next reply as private. You can upload the plugin files to Google Drive or Dropbox and share the download link in the next response.

September 27, 2018 at 2:53 pm
September 27, 2018 at 3:07 pm #2771001

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If the 500 error persists with the permalinks manager plugin disabled, then I do not think it is related to permalinks manager. It sounds like you were able to resolve that particular issue, and we probably don't need to contact the plugin author.

If this 500 error issue is in fact happening with Permalinks Manager disabled, please open a new ticket since it seems unrelated. Also, when you open the new ticket, it will be helpful to post any errors you see in the debug log.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines in your new ticket. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.