This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to update account information. I expected that the information would save; however, it does not. Solution: Deactivating and activating back all the plugins and the theme made everything go back to normal.

This topic contains 8 replies, has 2 voices.

Last updated by emirA-3 3 months ago.

Assigned support staff: Radu.

Author Posts
July 2, 2019 at 9:52 am #4125435

emirA-3

I am trying to: Update account information

Link to a page where the issue can be seen: /edit-address

I expected to see: I expected that the information would save; however, it does not. I've consulted this (https://wordpress.org/support/topic/problem-with-woocommerce-pages-edit-account-and-edit-address/) and noticed that there's a known issue, and was wondering how to solve it.

Instead, I got: The input information does not save, I get an OK 200 response.

July 2, 2019 at 11:01 am #4126037

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Emir,

Thank you for reaching out the WPML support!

I found the ticket from our forum regarding the topic that you attached https://wpml.org/forums/topic/woocommerce-pages-edit-account-and-edit-address-do-not-exist/. However, this seems to be a bit different since that user was missing some pages but, in your case, the pages are working but the changes are not saving (as I understand from your message).
Is there any chance that you could give me access to the dashboard area of your website so I can check this out a bit closer and see why is this happening, please? This way I'll be able to have a look at the settings.

Thanks,
Radu

July 2, 2019 at 2:16 pm #4127883

emirA-3

Hi!

You can sign-up here hidden link, just let me know when you do so that I can approve your account. Once you sign in, you should go to hidden link and try to edit your 'shipping' information. It's impossible to save the data once it's changed.

Please cc emina@east.ba

Best regards,
Emina

July 3, 2019 at 9:22 am #4133875

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Emina,

I created the account on your website? Can you give approve it, please?

Also, giving me access to an administrator account so I can access the dashboard area too would be great. This way I'll be able to have a look at the settings and see why the informations are not saved. The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

July 3, 2019 at 9:22 am #4133877

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Emina,

I created the account on your website? Can you give approve it, please?

Also, giving me access to an administrator account so I can access the dashboard area too would be great. This way I'll be able to have a look at the settings and see why the informations are not saved. The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

July 3, 2019 at 12:57 pm #4136589

emirA-3

Hi! Sorry, I didn't get any notification for an update on the thread. I just approved your account and made it an admin account. Feel free to test out with the credentials you signed up with. This is the link to your account details hidden link from which you can proceed to the edit address screen.

If you need any help, please contact me at emina@east.ba

Best,
Emina

July 4, 2019 at 8:08 am #4141077

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Emina,

Can you deactivate all the plugins except for WPML and WooCommerce, activate a default theme (like Twenty Nineteen for example), and tell me if you still cannot edit the account details, please? I just want to make sure that this is not an issue caused by the plugins or the theme that you're using.

Also, I can see that there are some JavaScript errors on the account page (please see the attached screenshot) coming from the Ramsbury theme that you're using. This might be causing the saving issue but doing the change I asked for will tell us more about it.

Thanks,
Radu

July 11, 2019 at 7:20 am #4186637

emirA-3

Hi Radu!

Once I deactivated and reactivated everything, the edit started working again, nothing short of a miracle. Thank you very much for your help and sorry to have taken your time.

Best regards,
Emina

July 11, 2019 at 7:21 am #4186639

emirA-3

My issue is resolved now. Thank you!