Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 2 voices.

Last updated by Carlos Rojas 6 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 3, 2020 at 9:28 pm #6287505

John

Bump

June 4, 2020 at 10:51 am #6293003

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,
I'm sorry for my late reply, it seems that this ticket was automatically closed by the system.
In any case, I re-opened it manually so we can keep working on it.

I just visited the site and the WPML plugins and Woocommerce plugin are still out of date. Could you update the outdated plugins and let me know if the issue persists after doing it?

Regards,
Carlos

June 16, 2020 at 6:44 am #6379923

John

Hello, what website have you visited actually? I am on my live site all translated and still I don't get emails correctly 🙁
Would you like a short video?

June 16, 2020 at 9:16 am #6381171

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

Yes, I screencast will allow me to see the issue and compare it with the steps I'm following 🙂

Regards,
Carlos

June 18, 2020 at 2:58 pm #6405281

John

Hey Carlos take a look here please.
Email footer doesn't get translated even if all is set up.
hidden link
Thanks

June 18, 2020 at 3:15 pm #6405415

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,
Thank you very much for the screencast shared.

I will escalate this ticket to our 2nd tier of support, but I before doing so I need to ask you to share the access credentials one more time, because I was using the credentials from the other ticket, but the other ticket was solved so the credentials were automatically removed.

I have set your next answer private so you can provide the credentials in a secure way.

Looking forward to your message.
Regards,
Carlos

June 18, 2020 at 3:26 pm #6405507

John

Hey the answer is not private 😀

June 18, 2020 at 3:28 pm #6405517

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
It seems it was an error.

I have set your answer private again 🙂

Regards,
Carlos

June 18, 2020 at 3:35 pm #6405603

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,
Thank you very much for sharing the access credentials again.

I already escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at the issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Regards,
Carlos

June 18, 2020 at 3:40 pm #6405713

John

Many thanks, Carlos, finger cross

June 18, 2020 at 3:45 pm #6405733

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

You are welcome! 🙂

Thank you very much for your patience
Regards,
Carlos

June 29, 2020 at 7:28 am #6473183

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,
I'm sorry for the late reply.

Our specialists in the 2nd tier of support solved this issue by following these steps:
- Update Woocommerce and WPML (I tested using DEV versions)
- Go to WPML > String Translator and search for the string
- Delete the string
- Go to Woocommerce > Settings > Email
- Modify the footer text then save
- Go to WPML > String Translator and search for the new string
- Translate the new footer string
- Now the footer was sent in the correct language (see screenshot)

Note: If it does not work at the first try, please also test with DEV versions.

Could you confirm that the issue is solved?

Regards,
Carlos

June 30, 2020 at 4:42 pm #6488869

John

Hello,
Sorry but this still doesn't work 🙁
hidden link
The translation is messed up ...
If you need more info please let me know

July 1, 2020 at 8:43 am #6492501

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,
Thank you for your message and for sharing the screencast.

I have already updated our 2nd tier specialists and they will take another look at this issue.

I will get back to you as soon as I have an answer from them.
Best regards,
Carlos

July 7, 2020 at 7:05 am #6535725

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John,

Our 2nd tier specialists followed the same steps I provided in this message https://wpml.org/forums/topic/woocommerce-email-doesnt-get-translated-even-if-all-strings-are-translated/page/2/#post-6473183
and the issue with the email footer was solved. You can see it in this screencast: hidden link

Regarding the header, this is expected. The "new order" emails are always sent in the same language (admin language - in this case, English), regardless of the client language. It means that it's not possible to translate this string (e.g. New order from French client). You can set a unique header on Woocommerce > Settings > Emails > Email heading that will be used for orders in all languages.

Best regards,
Carlos