Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Gerard 4 years, 7 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
March 19, 2017 at 4:31 pm #1234002


I am trying to:
Translate the woocommerce >> emails >>> email sender options >>> footer
URL of (my) website where problem appears:
hidden link
I expected to see:
To see three individual contents for EN, FR and DE
Instead, I got:
the same contents on all three languages. The correct translations are visible under string-translations. They are however not visible when emails are sent / received. The text under woocommerce >> email sender options >>> footer can be changed in any of the 3 languages and it automatically transfer the text entered to the other languages.
Steps to duplicate the issue:
Text is correctly translated under string translator
under woocommerce >> emial >> footer >>> the same English text is shown in our 3 languages.

Bildschirmfoto 2017-03-19 um 17.29.40.png
Bildschirmfoto 2017-03-19 um 17.30.23.png
March 20, 2017 at 1:26 pm #1234675

Ahmed Ibrahim

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi and thanks for contacting our support forum.

I have tried to replicate the issue on a clean installation using the "Twenty Seventeen" theme, and the email has been sent correctly with the footer translated.

So first please go to WPML -> Theme and Plugin Localization, and then make sure that you have selected this option "Translate the theme and plugins using WPML's String Translation and load .mo files as backup"

If this is not helping, please try the minimal environment, which means only WPML and Woocommerce plugins with one of the default WP themes active, this will show us if it is a compatibility issue or not.

For testing purpose, you can use this plugin: to catch the emails before sending them, and you can view them locally, by visiting Tools -> Email Log.

Best Regards.

March 20, 2017 at 3:32 pm #1234850


Dear Ahmed,

thank you very much for your kind feedback. What we did before your highly appreciated feedback arrived was to delete all of the content in the different languages.

After that we entered the same text in the English page only. That text was then also shown in other languages but we ignored it and went to perform the tranlsation in string translation and, yabadabaduuuu, the translations showed up correctly!!!

Thus, for whatever reason (most probably, as we did something wrong in the beginning (speak on different page we added texts in different languages) and that misguided WPML; which we find a truly great plugin!!!

for your support I very much thank you and I hope to help some others who sometimes get "lost in translation".

with my kindest regards,