This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by johannV-2 5 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 15, 2019 at 2:09 pm #3613943

johannV-2

Hi Shekhar,

I am also facing another problem. Usually Woocommerce emails are send in the language the customer choose. Out of the sudden they are all send in the sites default language which is English. I tried to look into all possible settings without success. Deactivating plugins is not helping either. Could you please have a look?

Thanks, Johann.

April 15, 2019 at 2:15 pm #3613961

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

That seems unusual, could you please change the theme to the default theme and let me know if that helps.

Also, can you try to create a simple WooCommerce Product and see if the problem exists?

Thanks

April 15, 2019 at 6:30 pm #3615789

johannV-2

I change my theme from child theme to default theme, created a Woocommerce Simple Product, marked it as virtual, set a price and translated that product in different language.
The problem is still the same. All Woocommerce emails are send in default language (English) even though I bought the product in German. Its strange...
I used a plugin to customize Woocommerce emails a while ago, but when doing so I never faced this issue. Dont know if this might have caused some problems, but the plugin is deactivated and cache is cleared... Should work properly 🙁

April 16, 2019 at 6:36 am #3618459

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just checked the translations of the strings used in the emails and can see that they all are loading from the .mo files but the correct settings to load the translation from .mo file is not selected in WPML->Themes & Plugin Localization.

So, could you please go to WPML->Themes & Plugin Localization, enable "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" and let me know if this helps.

Please test it after clearing the cache? if the problem still exists, would you mind providing me download details of the Woocommerce email plugin?

Look forward to your reply.

Thanks

Thanks

April 17, 2019 at 5:59 am #3627293

johannV-2

Unfortunately WPML is recommending me to disable that option in a notification... Guess thats why I disabled it at some point. Anyway I enabled it and cleared the cache. Its still the same, emails are send in default language no matter which language the customer choose.
But there is more. The bottom of the emails have a Support section provided by my multi vendor plugin. The emails the customer receives are showing this section in default language. The emails the admin receives are showing this section in the language the customer selected. Strange. I attached 2 screenshots.
The plugin i had used for editing Woocommerce emails is he following:
hidden link
They support multiple languages as you can edit each email in different languages. Dont know if this plugin messed something up when I had it installed...

April 17, 2019 at 10:02 am #3629371

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

In order to be better help on this issue, I have escalated this issue to our 2nd tier supporter.

Our 2nd tier supporter will take a look at this issue. Once they provide any feedback, I will get back to you with that feedback here.

Thanks

April 18, 2019 at 6:49 pm #3641523

johannV-2

Thanks Shekhar, you got any update yet?

April 19, 2019 at 5:47 am #3643663

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Not yet, it's still on our 2nd tier queue, I will update you as soon as I will have a further update.

Thanks

April 23, 2019 at 4:17 am #3659597

johannV-2

My issue is resolved now. Thank you!