This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 4 voices.

Last updated by Caroline 6 years ago.

Assigned support staff: Dominykas.

Author Posts
June 25, 2013 at 2:01 pm #138850

Madalin

Hello,

I seem to have a problem in having the emails sent, when using WPML. ALL the emails (even the password reset ones) are NOT being sent.

The issue seems to appear when in the Theme and plugins localization i am using Translate by WPML. If i am using translate using .mo files, the emails are getting sent.

I've tried searching the forum and haven't found ANY solution to this. I must say i didnt try to downgrade as said in a few other posts.

Here's my setup:

WordPress: version 3.5.2
WooCommerce Version 2.0.12
WPML Multilingual CMS Installed Yes 2.8.2
WPML CMS Nav Installed Yes 1.2.7
WPML String Translation Installed Yes 1.7.1
WPML Sticky Links Not installed No n/a
WPML Translation Management Installed Yes 1.6.1

Please advise, as this is an urgent matter. If required, i can provide full acces to the wp-admin.

June 25, 2013 at 2:26 pm #138866

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear Madalin,

Please, you could disable all plugins and using the default theme for WordPress? Check that you receive emails - eg to reset the password of WordPress.

This is important to know if it's some plugin/theme or the server that is causing this failure.

Thank you.

June 25, 2013 at 2:29 pm #138867

Madalin

I've already done that. I managed to find the issue. And that seems to be the one i already told you in the previous post.

If i simply disable ALL plugins, everything works fine. If i enable the ones previously stated and select translate by .mo files, everything WORKS, but then again, i cannot translate everything.

June 25, 2013 at 3:24 pm #138898

Madalin

Bruno, i'm still waiting for a hint, or a solution..

June 25, 2013 at 3:52 pm #138910

Madalin

It looks like the fact that's this is URGENT has NO EFFECT on the support speed.

Let me repeat, this is URGENT!

June 25, 2013 at 8:20 pm #138992

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear Madalin,

Sorry for the delay. Please, within your wp-config.php file, add the lines

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);

Try sending some email again and then check if any error message was displayed - the log file will appear in the wp-content folder.

Please let me know if any error message is displayed.

Thank you.

June 25, 2013 at 8:37 pm #138999

Madalin

Bruno, the only lines i am seeing are:

[25-Jun-2013 20:34:42 UTC] PHP Notice: Woocommerce::mfunc_wrapper is deprecated since version 2.0.0 with no alternative available. in /home/***/sites/***/wp-includes/functions.php on line 2843
[25-Jun-2013 20:35:04 UTC] PHP Notice: Woocommerce::mfunc_wrapper is deprecated since version 2.0.0 with no alternative available. in /home/***/sites/***/wp-includes/functions.php on line 2843
[25-Jun-2013 20:35:12 UTC] PHP Notice: Woocommerce::mfunc_wrapper is deprecated since version 2.0.0 with no alternative available. in /home/***/sites/***/wp-includes/functions.php on line 2843

I am willing to provide you with FTP access and/or wp-admin access if required..

June 26, 2013 at 12:25 pm #139221

Madalin

Hello ?

June 26, 2013 at 1:17 pm #139265

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear Madalin,

I'll assign your topic to one of our senior developers.

Thank you.

June 26, 2013 at 1:22 pm #139273

Madalin

I guess you could have done that in the first place 🙂

I'm an experienced WordPress user. Not very used to WPML, but from what i can see there are NO reasons the email should fail. No errors, no notices.

Since my previous posts i have also upgrade the theme to the last version and the mfunc_wrapper notice is gone.

I will provide FTP, and wp-admin access if required.

Again. This is URGENT.

June 27, 2013 at 6:21 pm #139658

Madalin

You people have NOT CLUE ABOUT WHAT URGENT MEANS ?!???

June 29, 2013 at 12:24 am #139997

Caroline

I'm having the same problems. I deactivated all non woocommerce and WPML plugins, installed 2012 theme and attempted to receive the reset password and it doesn't work. I can't receive the "processing" email. However, I do get the admin new order email and completed order email (but that last one is always partially or fully in the wrong language). I've posted about this second issue in a separate thread, but nobody got back to me.

Only activated plugins at this point:
WPML Multilingual CMS by ICanLocalize version 2.8.2,
WooCommerce Multilingual by ICanLocalize version 2.3.2,
WooCommerce by WooThemes version 2.0.12,
WPML String Translation by ICanLocalize version 1.7.1,
WPML Translation Management by ICanLocalize version 1.6.1

June 29, 2013 at 12:29 am #139999

Madalin

It's been FOUR (4) days since i opened this ticket. The only actual thing that helped was the last post stating that the ticket is going to be assigned to a SENIOR developer. But i guess it takes tham at least 3 days to even SAY HI!

I think i'm gonna ask for a refund. I was hoping to find a good team over here. Instead, all i can see is a forum full of bugs, and unanswered questions.

June 30, 2013 at 10:44 pm #140208

Caroline

Is everybody on holiday?
If so, please post a notice or something.

I went through complete reinstall or everything, which sucks because I also have to re-translate all the strings I had previously translated (didn't want to import tables in case there were errors in there).

Anyway, English (default language) emails appear to be working now, but as soon as I started including French translation of some strings for emails, they stopped working, except the Order completed (I no longer get the "new order email"), but it doesn't appear in the right language.

July 6, 2013 at 4:34 am #142106

hyung suk

My plugins set:

WordPress: 3.5.2
Woocommerce Multilingual: 2.3.2
WooCommerce: 2.0.12
WPML Multilingual CMS: 2.8.2
WPML String Translation: 1.7.1
WPML Translation Management: 1.6.1

English(default) emails works fine but Korean(my native language) emails do not work at all.
This is urgent problem. please help me!

The topic ‘[Closed] Woocommerce emails not being sent.’ is closed to new replies.