Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 1 year, 8 months ago.

Assigned support staff: Dennis.

Author Posts
December 13, 2018 at 2:23 pm #2998157

rolandd-5

Problem:
Email titles order are not in the correct language (always in browserlanguage)

I expected to seethe translations in de emails because they're set in WPML String Translations

December 14, 2018 at 7:25 am #3000775

Dennis

Hi,

Welcome to WPML Support forum. I’m glad to help you today.

#1

Please increase the PHP Memory Limit (your current setting is 64M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

+Keeping WPML within minimum requirements can help get rid of unusual errors.

#2

I would like to recommend updating your WPML and WPML add-on plugins to their latest versions. Please backup your website completely before updating WPML.

https://wpml.org/faq/install-wpml/#automated-updates

#3

Check out WPML Troubleshooting Options page: WPML > Support > Troubleshooting

- Backup completely your site. (important!)
- Click on the 'Clear the cache in WPML' button.
- Click on the 'Remove ghost entries from the translation tables' button.
- Click on the 'Set language information' button.
- Click on ‘Fix element_type collation’
- Scroll down a bit and find the "Recreate ST DB cache tables" button. Click it.

#4

1. Please remove the translation for those strings. Uncheck Translation is complete -> click Save.
2. Then re-scan your theme as well as plugins from WPML -> Theme and plugins localization.
3. Please re-add the translations for those strings at WPML -> String Translation and see if it resolves the issue.

Let me know your results. It would be better if you could share a screenshot of the string you’re trying to translate.

Regards,
Dennis

December 14, 2018 at 10:14 am #3001274

rolandd-5

Hi Dennis,

Thank you for your answer.

We're running the webshop on a server with Nginx, not the standard Apache. I don't know if the extra settings in config.php will be applied.

We haven't had this problem before. It started with our last update of WPML.
I know the plugins aren't fully updated. The last update was in end of September/ beginning of October. The problem started at that time because no update is done after that. And because we have almost no sales at the moment (season product only in summer), we just find this out.

Please see attached screenshots.

regards,

December 14, 2018 at 10:23 am #3001364

Dennis

Hi,

Thank for your patience and cooperation.

I would like to take a closer look at your site to help you better. For this, I would like to request temporary access (wp-admin and FTP) to your site. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

Kind regards,
Dennis

The topic ‘[Closed] WooCommerce emails title not translated’ is closed to new replies.