This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Radu 5 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
April 20, 2019 at 8:52 pm #3650755

qiangL-3

Tell us what you are trying to do? i'd like to translate woocommerce end points, danish and english version are just working fine, but the chinese version is not working as expected. all the links are pointing to the same link, i have no idea why?

Is there any documentation that you are following? nothing to follow

Is there a similar example that we can see? please find in the attached file

What is the link to your site? hidden link

April 22, 2019 at 12:50 pm #3655749

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Qiang,

Can you tell me if you tried to regenerate the permalinks by going to Dashboard → Settings → Permalinks and hit the Save changes button?

Also, you can follow the steps below:

  • go to Dashboard → WPML → Support → Troubleshooting → Clean up section;
  • Try the following options: Clear the cache in WPML, Remove ghost entries from the translation tables, Fix element_type collation, Set language information, and Fix post type assignment for translations.

Can you tell me if the problem is still there once you followed these steps? If so, please, what is the version of WPML and WP are you using? Can you please provide your WPML Debug information in the debug field below? You can find some more details about how to do this by checking the article http://wpml.org/faq/provide-debug-information-faster-support/.

Thanks,
Radu

April 23, 2019 at 2:37 pm #3664787

qiangL-3

hi,

i have done all process with the information you have provided, but it's not solved the problem

April 23, 2019 at 2:47 pm #3664981

qiangL-3

i forgot to write the versions. here it is .

WordPress 4.9.10
WPML Multilingual CMS Version 3.9.4
WPML String Translation Version 2.7
WPML Translation Management Version 2.5.2

April 25, 2019 at 11:59 am #3681993

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Qiang,

Please make sure that you:

  • installed the WooCommerce Multilingual plugin;
  • translated all the endpoints. You can check this by going to Dashboard → WooCommerce → WooCommerce Multilingual → Store URLs tab.

Here you can find a list with all the endpoints and will be able to translate them. Can you give this a try and make sure that everything is translated fine, please?

Thanks,
Radu

April 25, 2019 at 5:37 pm #3684759

qiangL-3

hi,

many thanks for reply, i have already done that, do you have another solution for this?

Many thanks in advance.

Best regards

April 26, 2019 at 9:08 am #3689085

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Qiang,

Can you give me access to the dashboard area so I can check these links and see why are they not translated, please? I just want to see how they are created and what can they be translated. Everything should be fine once you do the changes in WooCommerce Multilingual → Store URLs tab.

Thanks,
Radu

May 2, 2019 at 6:44 am #3722133

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Qiang,

I jsut checked the WooCommerce endpoints here hidden link and I could see that the orders and view order have now the same slug which is not actually a good thing. Can you make them be different again, please? Also, please deactivate all the plugins not related to WPML, activate a default theme (like Twenty Nineteen) and tell me if you still have this issue with the links to the orders page. This way we can see if this is an issue caused by one of the plugins you're using or maybe by the theme itself. Please let me know how this goes.

Thanks,
Radu

May 4, 2019 at 7:50 pm #3740943

qiangL-3

hi,

i have deactived all plugins and change the theme to the "Twenty Seventeen", but the those links still not working ,only after deactive "WPML Multilingual CMS", those links are working.

could you help please.

i'd like to hear from you as soon as possible.

many thanks in advance!

May 7, 2019 at 12:22 pm #3757647

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Qiang,

I had a closer look at your website and I could see that a lot of the plugins are outdated. Before checking this a bit closer, please update all of them to the latest version. A lot of things changed inside of WooCommerce too and this might be a problem that's already fixed in the latest version of our plugins. Before doing any update, you can create a backup of the website so you can roll-back everything in case anything goes wrong. Please give me a message back once the plugins are up-to-date.

Thanks,
Radu

The topic ‘[Closed] woocommerce end points translation give wrong links’ is closed to new replies.