This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 5 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 22, 2019 at 8:48 am #3654629

nickI-4

I am trying to: get the product gallery images in woocommerce

Link to a page where the issue can be seen: hidden link

I expected to see:gallery_image_ids array not empty

Instead, I got:empty array on gallery_image_ids

April 22, 2019 at 9:03 am #3654741

nickI-4

I have temporarily disabled "WPML Translation Management" plugin and it seems to be working.

What exactly this plugin does? Is it necessary to be enabled?
Thanks in advance

April 22, 2019 at 11:13 am #3655321

nickI-4

Woocommerce needs "WPML Translation Management" in order to work...
So please give us a solution.

Additional info on github
hidden link

April 22, 2019 at 5:39 pm #3657547

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You might be facing a known issue that we currently have.

There are two possible workarounds for now that you can try

1- Rollback to previous WCML version (4.5) you can get the previous WCML version from https://wpml.org/download/woocommerce-multilingual/?section=changelog,

(OR)

2- If you can handle a quick fix in the code.
Please open the file class-wcml-products.php located in the path wp-content/plugins/woocommerce-multilingual/inc/class-wcml-products.php

Approximately at line 689 comment the line
Change this:

$data['_product_image_gallery'] = null;

Into this:

//$data['_product_image_gallery'] = null;

Our developers are also working on the fix. the update will be released soon once the testing is done.


**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Let me, please know the results.

Thanks,
Itamar.

The topic ‘[Closed] Woocommerce get_gallery_image_ids empty array when Translation Management enable’ is closed to new replies.