Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 4 voices.

Last updated by sheldonN-2 8 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
December 11, 2019 at 7:46 pm #5110265

christoforosA

I am trying to: To make the variation image gallery to appear on translation.

Link to a page where the issue can be seen: sandals.tsite.eu

I expected to see: The variation image gallery to be copied to the translation.

Instead, I got: Only the main image of each variation is copied.

I have followed several threads on this forum but none helped.

December 12, 2019 at 5:56 am #5111901

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support.

I am going to attempt to recreate the issue on our end. In the meantime, it might be helpful for me to be able to take a look at your site, as I could not find an issue with your debug information.

Please back up your website before sharing any access. I will not make any changes to your site, but will check to see how the image gallery is being stored and why only one image is coming through.

If there is indeed a bug, I may need to escalate this to our developers but I'm hopeful that this is a configuration issue.

I've set your next response to private and it will be securely sent to us. You can safely share a temporary username and password with us this way.

Thank you!

December 18, 2019 at 8:32 am #5153315

christoforosA

Any updates on that??

December 18, 2019 at 7:02 pm #5157693

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Please allow us a little time to get through debugging this issue and I will update you as soon as I have some information for you.

Thank you!

December 19, 2019 at 5:36 pm #5165461

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry bout my last message. That was meant for a different client's variations issue.

I will update you regarding this shortly.

Thank you!

December 22, 2019 at 7:35 pm #5180185

christoforosA

Hey Hassan, Can you please help work this out?
I am in the middle of something. Is it going to take much longer?

December 27, 2019 at 10:17 am #5199915

christoforosA

Hi,

Do I have to pay extra in order to get support?
Is there any problem?

December 27, 2019 at 10:37 am #5199973

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Christoforos,

Sorry for this late reply. My colleague checked all the settings and, even though everything looks well, the images are still not showing up. He is not here for the moment but asked me to check this out a bit further.

I just want to let you know that I'm looking at this right now and give you another message soon, with some more details about my findings.

Thanks,
Radu

December 27, 2019 at 1:44 pm #5200735

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Christoforos,

I'm back, as I promised 🙂

I checked this issue a bit closer and I could see that the gallery field for variations is added by the theme that you're using (Woodmart).

In this case, could you edit a product that has this gallery issue, make sure that the language on the top admin bar is Greek, edit the variations, and add the gallery images here too, please? It seems that the images are not copied to this custom gallery but adding them manually should work fine.

Please give this a try and tell me how this works. In the meantime, I'll have another look at the theme and check this custom gallery field. I can see that some other user looked for this kind of change too (hidden link) and the change I presented (add the images manually) worked for him.

Thanks,
Radu

December 27, 2019 at 4:14 pm #5201433

christoforosA

Inserting all the galleries again for the translations is not a solution.
Manual work is not a solution.
I have 100s of galleries (each product has many different variations).
It is a ton of extra work. I thought that it is copied automatically.

Can I ask the theme creator to do something in order to make this work?

December 30, 2019 at 12:27 pm #5211083

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Christoforos,

I checked again your website but I could see that WPML is no longer available. I didn't activate it because I try not to change users websites without their permission.

Now, I agree with you that editing over 100 products is not the best idea. When I checked this out I found that the gallery should be saved on a field called woodmart_variation_gallery_data. I set this field to copy so that WPML can copy the value from this field. However, this didn't seem to do the trick. I guess that the gallery is saved in some other way.

In this case, could you try to reach out the theme authors and ask them to have a look at this and tell you if there's any other place (or way) that the gallery images are saved? I just want to understand how this field works so I can look for a way to make the values appear on the second language too. In the meantime I will create a new install using the same theme and see if I can find another way to do this change.

Thanks,
Radu

January 8, 2020 at 9:18 am #5252477

christoforosA

Hi,

I got a reply from the theme creators and it was:

"Our products variations galleries are stored in one place only. And it is meta value with a key woodmart_variation_gallery_data. You can see how it is used on the frontend in the file woodmart/inc/integrations/woocommerce/modules/variation-gallery.php."

That's all they replied.

January 13, 2020 at 9:09 pm #5285547

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Christoforos,

I already managed to identify that the images for the variations are saved in the woodmart_variation_gallery_data custom field. If you edit a translation of one of the products, like this one hidden link, you can see that the values of the woodmart_variation_gallery_data field (the ID of the images) are copied to the translated products.

I checked the file that the theme authors pointed out in their message. Since the IDs of the images are copied to the translated products (in which case the images should work fine on the translated product), could you ask again the theme authors if there's anything else that needs to be done here, please?

In the meantime I'll have another look at this to see if there's anything that slips through my fingers.

Thanks,
Radu

January 15, 2020 at 4:38 pm #5299603

christoforosA

The theme creator replied this:

It seems that it works correctly as you expect. The only problem is that the field is copied exactly with images IDs and variations IDs. But your translated product has DIFFERENT variations IDs. They are not fully copied. That is why these images are not applied on your translated product. So when you create the product translation, you create NEW variations with new IDs. That is why the copied field for variations images doesn’t work.

January 17, 2020 at 11:56 am #5311495

christoforosA

Then I got another reply which says:

You need to not copy these fields but select these images separately for translated products if possible from the WPML side.

The topic ‘[Closed] Woocommerce Image Variation Swatches not working in second language’ is closed to new replies.