Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.03 hours from now. Thank you for your understanding.

This topic contains 22 replies, has 4 voices.

Last updated by sheldonN-2 7 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
January 17, 2020 at 11:57 am #5311505

christoforosA

Did you check this? Did you find the solution to this problem?

January 20, 2020 at 10:49 am #5322629

christoforosA

Can you please tell if the reply from the theme author makes any sense to you.

"You need to not copy these fields but select these images separately for translated products if possible from the WPML side."

I fixed the product on your page. You only added the image in variation gallery but you need to added it also as variation's featured image.

I have opened this thread 40 DAYS ago and I still did not get any solution to my problem.
40 days and you now telling that you need to pass this to somebody else. Then what???

This is so disappointing... So many days and no solution...

January 21, 2020 at 1:30 pm #5332805

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Christoforos,

I think that the theme author is saying that you should add the images manually to each variation. As you could see in one of the threads from their support area, they are suggesting this option to all of their users: hidden link

While I can try to find out what's the fix for an issue presented on the ticket, there are things that are more complex where I need some help from developers (like in this case), when everything that I try is not working out.

As you can see, this is a compatibility issue between Woodmart and WPML. Now, I informed my colleagues about what I tried so far and what I found about the issue. They will have a look too and they will inform me if there's any change that can be done in order to fix this or if we need to work with the theme authors to sort things out.

I'll keep you posted about the progress we're making on this.

Thanks,
Radu

January 22, 2020 at 11:41 am #5340169

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Christoforos,

It seems that this issue is more complicated and that's why I had to escalate this to the compatibility team. They will check the way that the theme implemented the variation gallery. They will also reach out the theme authors to work together and look for a way to make the variation gallery be translatable using WPML, not just manually.

I will keep you posted about the progress we're making on this (and with a early fix, if possible).

Regards,
Radu

February 4, 2020 at 11:14 am #5420459

christoforosA

Did the compatibility team found out anything?

February 5, 2020 at 7:49 am #5427743

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Christoforos,

My colleagues started looking at this issue right after I send you my previous message. For now, I don't have any updates about this. They are still investigating this one and it seems that something's not working right on the front-end (even if the values are saved fine when saving the product settings).

I will definitely keep you posted on this, as soon as I have any news.

Thanks,
Radu

February 8, 2020 at 7:25 am #5451903

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Christoforos,

My colleagues managed to find a fix for this issue. I added a few lines of codes to the functions.php file from your website (you can see it at the bottom of the file). Once I did this, I went back to this product hidden link, make sure that the woodmart_variation_gallery_data custom field is set to copy, then check the translation hidden link

Can you have a look and tell me if the gallery is working as expected now, please? My colleagues also contacted the theme author to implement the fix on the theme too.

Thanks,
Radu

February 18, 2020 at 9:27 am #5513551

sheldonN-2

Hi, we are facing this same issue as christoforos, with Woodmart theme and the woodmart_variation_gallery_data fields not copied in the WPML translations.

We have already duplicated existing media using the media translations plugin , so the image ids for the original language and secondary translated language are different.

Could you please share the code to add in the functions.php and also steps to resolve the missing variation product gallery images for already translated products.

Edit : Our woodmart_variation_gallery_data field was not set to 'copy' but 'translate' earlier while creating the translations, so the data in the translated fields would be empty.

How can we get all the data from the original woodmart_variation_gallery_data field copied and apply the above fix after the products have already been translated.

The topic ‘[Closed] Woocommerce Image Variation Swatches not working in second language’ is closed to new replies.