This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 3 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
June 26, 2019 at 3:08 pm #4093493

tommasoD-7

Hello! I'm tryng to import some woocommerce products from a csv file for my second language (english)
I imported my products (with some variants) in my default language (italian), but when i import my products for the second language (english), no variant are shown.

I followed this documentation page: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

You can see this page: hidden link

The italian version of this page works: hidden link (but no variant are shown if I go to the english version of the page)

my website: hidden link (in coming soon mode)

June 26, 2019 at 8:33 pm #4095047

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Since your site is in the 'Coming soon' mode can you please share with me the access details and explain to me where I can see this issue on your site?
Also please tell me which import files (CSV files) you importing.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

June 27, 2019 at 9:27 am #4098509

tommasoD-7

I'm sorry, i forgot:
i used folliwing csv:
dati_2_it.csv
dati_2_en.csv

you can also find 2 import templates:

prodotti2-it
prodotti2-en

Something strange appears when managing imports (see the attached screenshot):
There are 2 blank imports running.
And if I try to run again an import it cannot execute the import

June 27, 2019 at 8:18 pm #4102819

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

On your site, I've updated the product and then its translation and now the attributes are showing. Please see the attached screenshot.
Can you see that it is OK now?

I can see the issue that you have in 'Manage Imports' of empty and currently in progress imports. But I do not think that it is related to WPML.

Regards,
Itamar.

June 28, 2019 at 6:54 am #4104885

tommasoD-7

Thank you so much!
How had you update the english product page?
I couldn't change the attributes, they were locked ...

June 30, 2019 at 3:12 pm #4114311

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Here is what I've done.

1. On the editing page of the Italian product, I pressed the "update' button.

2. Then I pressed the pencil icon to edit the English translation with WPML's Translation Editor.

3. I've checked the 'translation is complete' checkbox at the bottom of the screen, and I pressed the 'Save and Close' button.

Please see the attached screenshots.

When translating WooCommerce products, it is recommended to use WPML's Translation Editor. Please read our documentation about how to work with WPML and WooCommerce.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Could you please mark this issue as resolved?

Thanks,
Itamar.