This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bruno Kos 7 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
February 18, 2019 at 4:41 pm #3213362

Karl

Orders from the English part of this website show invoices and emails in Dutch language.

When I open up an invoice, it does not show language info at the custom field either.

Is this a known problem, or do you have a solution/explanation for it?

February 19, 2019 at 3:20 pm #3217556

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

February 20, 2019 at 8:16 am #3220209

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am trying to find a pattern here - for example, somebody ordered this product:
hidden link

However, no language custom field exist for it. On the other hand, this one has NL value:
hidden link

So in short - Dutch orders hold no value while English hold NL value?

Also, can you do/tell the following:
- do you have a staging area for this site where I could do some testing?
- if not, can you install this plugin https://wordpress.org/plugins/ari-adminer/ - so that I could check some thing in database (without changing anything)

Regards,
Bruno Kos

February 20, 2019 at 9:20 am #3220378

Karl

Hi

Plugin has been installed, I don't have a staging site.

February 20, 2019 at 11:19 am #3221126

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Not sure if you can provide this information - however, can you tell me if you remember or can check logs on what kind of change have you done around December 10th last year?

I've checked database - everything worked perfectly up to the order #1672. That one is the last that worked well and for which (post ID for that order is 2522) the wpml_language custom field was saved properly.

Did you install any new plugins then, update existing plugins or added a new theme? Or even switched hosting? I know this is along shot, but I am trying to understand what triggered the normal operation starting to fail.

Regards,
Bruno Kos

February 20, 2019 at 11:26 am #3221285

Karl

Hi Bruno

Only thing I can think of is updating plugins, but I cannot recall which ones.
We did not change hosting or added new plugins or different theme.

February 20, 2019 at 12:40 pm #3221710

Karl

ok, migration has been completed.

February 20, 2019 at 1:08 pm #3221876

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Great, I can see that everything is in place now! Would you mind trying to test there the following scenarios:

- order a product(s) from both languages as it is now
- then try the same while leaving only WooCommerce and WPML active, other plugins disable and using a default WordPress theme like Twenty Nineteen

I've activated Betalingen met cheque we can use for easy offline orders, so no need to bother with paypal or credit card orders, simply fill an order and place it.

Let me know how it goes!

Regards,
Bruno Kos

February 20, 2019 at 2:27 pm #3222183

Karl

Hi Bruno

All scenarios are working, and show wpml_language with either nl or en value:

1. tested as site was in both languages
2. tested with only Woocommerce and WPML active and on Nineteen theme
3. tested with all plugins enabled on Outrank Pro theme

So how come it works now, is there anything you have changed?

February 20, 2019 at 2:58 pm #3222375

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have not changed anything, that's the thing. I only activated cheque so that we can try offline purchases. Can you try with cheque gateway on your site as well? If it has nothing to do with cheque, then it could be something related to server and database.

It could also mean that it is something related to payment gateway, but this is just a guess - did you use PayPal before 10th December?

Regards,
Bruno Kos

February 20, 2019 at 3:11 pm #3222477

Karl

I tested with Cheque gateway on live site and that works too!

Yes, we did use PayPal before 10th December.

February 20, 2019 at 3:31 pm #3222595

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I see - it could be that something has changed on the way this data is returned from PayPal or other payment gateways.

On this site - hidden link

I've updated all the plugins. I would recommend we start testing with PayPal with the following:
- - then try the same while leaving only WooCommerce and WPML active, other plugins disable and using a default WordPress theme like Twenty Nineteen

I am not sure how to test this, though - perhaps setting a product with the price 0 and then run it through PayPal or using something like this and checking if the wpml_language will return.

hidden link

Not sure about the way you set this on your site, can you check it out?

Regards,
Bruno Kos

February 20, 2019 at 3:48 pm #3222727

Karl

I tested a virtual product with price of zero, so that bypasses the payment gateway.
That went well.

I saw an order of 3 hours ago through the payment gateway, that also went wel.
There was an update earlier on Mollie Payment gateway. Maybe that is solved. I will try to reproduce with a priced item now and going through payment gateway, but most likely, the problem lies there.
Will keep you informed! Thanks so far for your help!!

February 21, 2019 at 7:18 am #3225188

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Great, let me know once you'll have more new results!

Regards,
Bruno Kos