We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Lauren 6 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 20, 2019 at 9:44 am

lilyM

My default language is English. There seem to be no problems concerning accessing products in this language. However, when attempting to visit products categories in my 2nd language Italian, categories and products are VERY slow to load or will not load at all.

I have also seen the following error:

Fatal error: Maximum execution time of 180 seconds exceeded in /public_html/wp-includes/class-wp-hook.php on line 277

While it is not happening every time, it is happening MOST of the time, and only in the Italian category.

An example url is: hidden link

But please visit any of the product categories found at the following url for examples of slow or no load times:
hidden link

Can you help me resolve this? Thank you!

April 22, 2019 at 5:56 pm #3657655

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

April 23, 2019 at 8:25 am #3660555

lilyM

Hi Lauren - Thanks for your response. I've updated all WPML plugins & WordPress core, disabled all plugins except WPML related and then temporarily changed the theme to a default WordPress theme as requested. Doing so DID NOT resolve the issue. I'm still getting the same hang time or no-load when attempting to visit products categories and product pages, but ONLY in my 2nd language Italian. Everything works fine in my default English.

Can you help me resolve this? Thanks again.

April 23, 2019 at 4:47 pm #3666339

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

April 24, 2019 at 8:12 am #3670193

lilyM

Done - Thanks again:

[24-Apr-2019 08:04:06 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:05:40 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:05:58 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:06:22 UTC] PHP Warning: Error while sending QUERY packet. PID=2794230 in /public_html/wp-includes/wp-db.php on line 2007
[24-Apr-2019 08:06:41 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:06:56 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:08 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:12 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:20 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:24 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:27 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:48 UTC] PHP Fatal error: Maximum execution time of 180 seconds exceeded in /public_html/wp-includes/post.php on line 730
[24-Apr-2019 08:07:49 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:07:49 UTC] PHP Warning: Error while sending QUERY packet. PID=2794230 in /public_html/wp-includes/wp-db.php on line 2007
[24-Apr-2019 08:07:50 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-content/plugins/really-simple-ssl/class-mixed-content-fixer.php on line 111
[24-Apr-2019 08:08:30 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:09:01 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212
[24-Apr-2019 08:09:02 UTC] PHP Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /public_html/wp-includes/functions.php on line 4212

April 24, 2019 at 7:10 pm
April 24, 2019 at 7:11 pm #3676209

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I have sent you a private reply previous to this one. Please let me know once the migration is completed and I will continue troubleshooting on the staging site. Thanks!

April 24, 2019 at 7:58 pm #3676553

lilyM

Migration is underway. Because of the time difference (I'm in Italy) I probably wont be awake by the time the migration is complete. Would you be so kind as to check its status in a couple of hours or so and continue troubleshooting? Thanks again.

April 25, 2019 at 4:44 am #3678831

lilyM

Migration is complete.

April 25, 2019 at 7:24 pm #3685503

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks so much for migrating the site. In the test site, I switched to default theme and deactivated everything except WPML and WooCommerce plugin. Then, I went to WPML -> Support -> Troubleshooting and ran the steps in the Clean Up section.

Next, I went to WooCommerce -> WooCommerce Multilingual -> Status and clicked Troubleshooting and ran the steps there. After this, I saw a much faster response time. Could you please test this on your site after making a full backup? Please let me know if there is any change in performance.

Also, be sure you are using the latest versions of WooCommerce and all WPML plugins.

April 26, 2019 at 5:14 am #3687797

lilyM

Before I go through the process of doing this again, because I have already done it once, can you just tell me what the problem is and how it can be resolved? Can you see a way to resolve it in your test area? if so, can you tell me what to do on the live site?

I am using the Woocommerce Storefront theme and like it. I do not want to make a permanent switch to another theme so it is necessary to find a solution with this theme. Thanks.

April 26, 2019 at 3:30 pm #3692025

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I think the issue was related to caching on my test site, which is why I think the cleanup steps resolved the issue. Once you run these steps and see that the site is running well, then you can switch back to Storefront theme and make sure nothing changes. If all goes well, then I recommend activating the other plugins one at a time to make sure we don't find any conflicts.

April 27, 2019 at 5:18 am #3694619

lilyM

Following those steps does not seem to have resolved my issue. However, I noticed something that may be relevant: When I am experiencing a slowed product or product category load time, I see a CPU Usage warning in my cpanel STATISTICS, indicating that I am at 100% of my CPU Usage. The warning goes away when I discontinue my attempt to load that product or category. This ONLY happens when I attempt to use the Italian language product categories.

Could there be a connection? But why only on my Italian language and not the default English? Does the 2nd language draw more CPU Usage? If so, is there a way to resolve it?

Thanks again.

April 29, 2019 at 5:07 pm #3705761

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

That is not expected behavior, and I suspect it may be a plugin or theme conflict causing this issue. Are you experiencing the same behavior on the test site that I set up? The test site has minimal settings, and the Italian categories are loading without any issue for me. Can you please test there and let me know if you are seeing the same?

If you are seeing the same, let's try minimal settings on your live site. Then, clear the cache and also run the cleanup steps at WPML -> Support -> Troubleshooting. Please make sure you have a full backup of your site before these steps.

Then, if you are not seeing slow load times, let's reactivate plugins one at a time to see if we can determine if there is a conflict with one. If all plugins activate and the issue is not happening, reactivate your current theme and see what happens.

I will be happy to test this for you, if you can give me permission to run these tests on your live site. Otherwise, please let me know the results. You can use Query Monitor plugin to let me know the load times that you are experiencing on your live site with these settings.

April 30, 2019 at 5:54 am #3707995

lilyM

Yes, you have my full permission to run these tests on my live site. I've made full backups.

I provided all the access details to my site when I started this thread, but if you need anything else please let me know.

Thanks!