This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 12, 2019 at 5:01 pm

Omer

Hello;

After i updated the plugin to the latest version i am getting strange issues.

Some of the customer who placed and order getting english email instead of turkish. I think its because they are using english language in their browser. Whenever this happens those transaction is not sent to google analytics. We have like 100 transaction today but only 12 of them was in Turkish and the others ones are english. And they are all from Turkey and they should get turkish email.

How can i prevent this?

Thanks

July 15, 2019 at 11:15 am #4210325

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I think it because they are using the english language in their browser.

Do you mean they have set the English Language as default in the browser or they are purchasing the products using the English language?

Do you have browser redirection enabled? If so can you disable it and see if this helps?
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

Look forward to your reply.

Thanks

July 15, 2019 at 3:16 pm #4212749

Omer

Hello;

Browser redirection is disabled and you can only use turkish language for Turkey shipment so they have no chance to use english version of the site.

if you are using english version of the browser you get the english mail even if you choose ship Turkey.

Thanks.

July 15, 2019 at 5:50 pm #4213875

Omer

After updated the latest version of wpml we are having duplicated orders one of them is turkish one of them is english. I need to fix it asap!

July 16, 2019 at 4:02 am #4215891

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, to further debug this issue, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

July 16, 2019 at 4:12 am
July 16, 2019 at 4:40 am #4216129

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you please provide me a few products example with addresses to fill out to reproduce this issue?

Also, can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

July 16, 2019 at 8:05 am #4217423

Omer

Hello;

Orders:
#37012
#37011
#37006
#37005

Product:
hidden link
hidden link

I asked this customer what happened and she said that "i didnt see transaction completed page and i re-order."

As you can see in the orders details 2 of them are english, 2 of them are turkish. Something strange happened when customer fill credit card form and make payment and redirecting. Its sometimes redirect to english page and sometime turkish page.

All the customer from Turkey included this one, must use turkish page to fill adress. Because they can only use Turkish language if they want shipment to Turkey. Even I can see both English and Turkish order details in woocommerce orders.

Thanks.

July 16, 2019 at 8:17 am #4217569

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just created a new order myself and it's sending the email in correct language so can you check the issue once more and see if the emails are sent correctly?

Look forward to your reply.

Thanks

July 16, 2019 at 8:20 am #4217575

Omer

Hello;

I doesnt happened all the time and i think if you choose bank order you are not able to see this problem. I think its happened when credit cart information sent and come back to our server.

July 16, 2019 at 11:46 am #4219739

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Strange, since this is not happening every time as you mentioned, it would be really hard to reproduce the issue, being so I request you to keep monitoring your site and try to see if you can find a way to reproduce the issue.

I would also request you to test the issue on the following scenerio and let me know the results

#1
Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#2
Could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

July 16, 2019 at 3:20 pm #4221677

Omer

Hey;

We solved the clone transaction. Can we focus on the disable browser redirection?
Customer who placed an order even in turkish language in website got english mail.

July 17, 2019 at 4:30 am #4225831

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I received emails in Turkish order so can you try again and see if the problem is replicable? Did you try the steps I mentioned earlier?

Look forward to your reply.

Thanks

July 17, 2019 at 4:42 am #4225839

Omer

I cant disable all plugin in live site and there is a small chance to get this error on staging server. We are still having this problem as you can see in this screenshot.

Thanks.

July 17, 2019 at 4:44 am #4225887

Omer

Btw, when customer completed an order with english browser instead of turkish, google analytics cant get the conversion data. Latest updates broke something :

The topic ‘[Closed] Woocommerce multilanguage email forms’ is closed to new replies.