This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Timmy Leung 11 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
October 21, 2018 at 12:01 pm

Timmy Leung

I am trying to: Add/Edit Chinese content on an existing English product record.

Link to a page where the issue can be seen:
hidden link

I expected to see: Something like any editor or content comparison UI.

Instead, I got: Web Browser Timeout, it seems its loading something outside of my site, its look like unable to access wpml.org site for something.

October 22, 2018 at 9:09 pm #2839828

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I have just connected to your site and attempted to translate a product. Clicking on the "+" icon opened the Advanced Translation Editor (ATE) without any timeout issue.

It may be that there was a momentary issue that has since gone away. Can you confirm if this is still an issue for you?

If it happens again, you can try switching to the Classic Translation Editor (CTE) and then notify us about the ATE delay so we can check our servers.

To switch to the CTE , go to WPML -> Settings-> How to translate posts and pages -> Translation editor options

October 30, 2018 at 12:20 pm #2861605

Timmy Leung

I am trying to do it again tonight. But I have got the following error message:

Fatal error: Uncaught RuntimeException: <p><p>WPML cannot send these documents to translation because the Advanced Translation Editor is not fully set-up yet.</p><p>Please open the confirmation email that you received and click on the link inside it to confirm your email.</p><p><a href="hidden link">Resend that email</a></p></p> in /home/users/0/3tp/web/3tp.jp/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ate-jobs-actions.php:426 Stack trace: #0 /home/users/0/3tp/web/3tp.jp/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ate-jobs-actions.php(321): WPML_TM_ATE_Jobs_Actions->check_response_error(Object(WP_Error)) #1 /home/users/0/3tp/web/3tp.jp/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ate-jobs-actions.php(272): WPML_TM_ATE_Jobs_Actions->update_jobs(NULL, Array, true) #2 /home/users/0/3tp/web/3tp.jp/wp-includes/class-wp in /home/users/0/3tp/web/3tp.jp/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ate-jobs-actions.php on line 426

October 30, 2018 at 12:26 pm #2861615

Timmy Leung

In addition, why my site language - Japanese has disabled during the supporting?

October 30, 2018 at 12:27 pm #2861617

Timmy Leung

When I try to add back the Japanese languge, I found it has not able to be added back.

October 30, 2018 at 12:29 pm #2861619

Timmy Leung

Finally, the Japan lanauge could be added back. But all Japanese products record gone. What should I do?

October 30, 2018 at 12:31 pm #2861622

Timmy Leung

I have found all Japanese Cats and Tags are all gone also, not only products records!!!

October 30, 2018 at 12:45 pm #2861675

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. ATE messages
Did you open the confirmation email from the ATE and click on the link it included inside?

2. Language settings
OK

3. Japanese Data
I am going to check this now for you. I have not entered your system since 22 October when I confirmed everything was normal.

October 30, 2018 at 12:51 pm #2861689

Timmy Leung

Hello

1. ATE messages
Did you open the confirmation email from the ATE and click on the link it included inside?

ATE? No ATE email have got.

2. Language settings
OK

3. Japanese Data
I am going to check this now for you. I have not entered your system since 22 October when I confirmed everything was normal.

I have not login to the site since 22 Oct also. When I login to the site tonight, the Lang setting only have Eng and TChi.

October 30, 2018 at 1:02 pm #2861757

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I have just confirmed that the ATE server is down at the moment, so I have changed your editing mode to use the CTE (Classic Translation Editor) so you can continue to work.

October 30, 2018 at 1:06 pm #2861761

Timmy Leung

How to recover all Cat, Tag, Product records that related to Japanese?

October 30, 2018 at 1:28 pm #2861996

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I am checking into this. Would you be able to confirm that you created all of your JA data using the ATE editor?

October 30, 2018 at 2:13 pm #2862167

Timmy Leung

It might be.... It was translated with the new GUI, other than input information on normal product post page.

October 30, 2018 at 3:53 pm #2862586

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I can see that the ATE server has been restored and that you are using it again with no errors.

I´m still not clear what could have happened with the products or categories. The fact that you did not have JA language at some time makes me think that the products and categories are present but assigned to the wrong language.

Can you check if this is possible? Can you find your japanese categories in the English or Chinese langauge spaces?

If so, then we can reassign the products/categories to the correct language.

October 30, 2018 at 4:08 pm #2862641

Timmy Leung

Chinese Products/Cats/Tags records are now only have Chinese content.
English Products/Cats/Tags records are now only have English content.
Japanese stuff all gone! You can extract my backup file to see it. Japanese records must stored before supporting.
Wnen I login again (I have not touch the site for WPML supporting since I have create the ticket), the WPML setting have selected Eng and TChi only. It is the major problem I have found. Why the supporting procedure require to remove one lang option?