Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.35 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 2 years, 6 months ago.

Assigned support staff: Bruno.

Author Posts
May 24, 2017 at 11:54 am #1283577

szilardM-2

I am trying to: Use WooCommerce Multilingual with the WooCommerce Membership extension. My problem is that if I have more than one content (page) for members only then under My Account the my membership contents have all the same url link. They have all the link of the first content in the list. If I disable WooCommerce Multilingual then al the contents get their own link, and everything is ok. Please check the screenshots enclosed.
I activated the basic storefront theme and disabled all the plugins except WooCommerce, WooCommerce Membership, WooCommerce Multilingual, and all the plugins the WC Multilingual needs (WPML Media, WPML Multilingual CMS, WPML String Translation, WPML Translation Management). All these plugins are updated but this issue was around before update as well.
If I disable any of the WPML plugins, the issue is gone, all the links are good. I think it is because the WooCommerce Multilingual is working only if all these plugins are activated.
So everything shows me that the issue with the My Membership Content links are caused by the WooCommerce Multilingual plugin. Could you check this?

Best,
Szilard

May 24, 2017 at 10:07 pm #1284054

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us.

When I try to access your site, it appears that the page is under construction.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 25, 2017 at 9:00 am #1284293

szilardM-2

Hi,

I have only one staging site and it is used at the moment for debugging another issue.
I'll be back with the login information once the other issue is solved and we can use the staging site to check this issue.

Thanks,
Szilard

May 25, 2017 at 5:40 pm #1284799

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sure. Please let me know when you're ready. Your next message will be private.

Thank you.

The topic ‘[Closed] Woocommerce Multilingual and Woocommerce Membership – wrong links to content’ is closed to new replies.