This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Vincenzo 1 year ago.

Assigned support staff: Vincenzo.

Author Posts
October 15, 2018 at 4:51 pm #2818355

bojanJ-3

I am trying to:

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:
I can not use the Customizer anymore, I get in Customizer:

Warning: Invalid argument supplied for foreach() in /homepages/45/d735189978/htdocs/app735190044/wp-content/plugins/woocommerce-multilingual/inc/currencies/currency-switcher/class-wcml-currency-switcher-templates.php on line 100

Fatal error: Call to a member function get_scripts() on null in /homepages/45/d735189978/htdocs/app735190044/wp-content/plugins/woocommerce-multilingual/inc/currencies/currency-switcher/class-wcml-currency-switcher-templates.php on line 419

October 17, 2018 at 8:05 am #2823643

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

From the error message, it seems like the Multi-currency option is enabled but no other currency has been added.
- You can verify it in WooCommerce -> WooCommerce Multilingual -> Multi-currency

It is also possible that a currency switcher has been added in a widget or in the product page template, but the "Template for currency switcher" field is empty.
- You can verify this in WooCommerce -> WooCommerce Multilingual -> Multi-currency by clicking on the blue pencil icons.
If the "Template for currency switcher" field is empty, try adding the following code:

%name% (%symbol%) - %code%

Please let me know if this solves the issue or if you need further details.

Thank you