This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 2 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 26, 2019 at 3:37 pm #4290477

Marco Scalone

Hello,
I have an issue with the WooCommerce Multilingual plug-in.

Today I installed the plug-in extension, but it totally broke the back-end products layout.

The layout of the translated shop page is a mess and the “Add to cart” button disappeared.

Can you help me? What am I doing wrong?

Thank you.

July 26, 2019 at 7:07 pm #4291399

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

WPML(core plugin) is already active on your site and the issue happens just after activating WooCommerce Multilingual plugin today, am I right?

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

July 29, 2019 at 7:16 am #4297287

Marco Scalone

Good morning,
yes, you're right!

Here's the debug info.

Thank you, have a good day.

July 29, 2019 at 2:31 pm #4300887

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and Debug information. I have couple of requests to track the issue.

1) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

2) Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

July 30, 2019 at 4:07 pm #4309553

Marco Scalone

Hello,

here's the debug log: https://pastebin.com/VW27bbr6

I tried to deactivate all the plugins but nothing seems to change.
I disabled the yoast SEO meta box and the back-end products layout works again.

Thanks.
Have a nice day.

July 30, 2019 at 5:51 pm #4309945

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The Debug log is not showing any error or warning related to WPML.

So I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Please ignore my last reply, the one you have received via mail. It was a mistake.

--
Thanks!

Bigul

July 31, 2019 at 2:28 pm #4315285

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. This may be a compatibility issue. So to make sure, please switch for a moment to default 2019 theme after site backup and make sure the Shop and individual Product page is showing *Add Cart* button in secondary language.

I have a request. Please upgrade the following configuration for the better performance for the site. May improving these configuration will help us to solve the issue.

1) Upgrade PHP version to 7.2 or greater, the recommened PHP version for WooCommerce and WooCommerce Multilingual. Please check this article for more details -- https://docs.woocommerce.com/document/server-requirements/

2) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

3) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

Please try it after a site backup and let me know your feedback.

--
Thanks!

Bigul

July 31, 2019 at 4:35 pm #4316817

Marco Scalone

Hello,

I switched to the default theme and I can see the "add to cart" button into the Shop page.
Also the single product page works fine.

1. I cannot upgrade the PHP version to 7.2. Currently is 7.1;

2. I increased the WP Memory Limit to 256;

3. I created the php.ini file and I added this code into .htaccess file:

<IfModule mod_php5.c>
php_value max_input_vars 5000
</IfModule>

Unfortunately the translated shop page is still a mess.

August 1, 2019 at 6:20 am #4319005

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. This may be a compatibility issue with Luxwine theme. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Please note, *MaxInputVars* is not increased yet. It is still showing the value as 1000.

--
Thanks!

Bigul

August 1, 2019 at 10:33 am #4320583

Marco Scalone

Hello,
The Duplicator package is ready.
You can log into the website and download the file.

I followed some tutorials but I can’t increase the Max Input Vars value, it gives me an “Internal Server Error” message.
If you want I can provide you the FTP credentials.

Thank you,
have a nice day.

August 2, 2019 at 8:03 am #4327857

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and Duplicator package. I am debugging the issue on my local server now. The Add Cart button is showing in English on Shop and Products page when *Advanced Custom Fields PRO* plugin is inactive. Please check the attached images for more details.

So please share me more details of *Advanced Custom Fields PRO* usage on your site. Are you calling ACF fields in theme templates or have you made any changes in the theme files?

--
Thanks!

Bigul

August 2, 2019 at 10:59 am #4329179

Marco Scalone

Good news!

While I was searching for some details about the Advanced Custom Fields PRO plugin, I noticed that the Store Settings into Theme Options were reset even if I surely activated them.

Both translated Shop page and Single product page finally work!

Thank you for your patience.
You gave me great tips.

Have a nice day.

August 2, 2019 at 7:18 pm #4332273

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I am getting the expected result in my local copy after the following steps. Please try it after a site backup and let me know your feedback.

1) Go to Appearence>>Theme Options
2) Switch to English via Dashboard language switcher
3) Click on the Store tab
4) Enable the store options(same like Italian ones)
5) Update the changes

Please check the attached images for more details.

--
Thanks!

Bigul