This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 11, 2018 at 1:26 am

Arturo

I am trying to: Activate and update

Link to a page where the issue can be seen:

I expected to see: Update

Instead, I got: error messages for all three plugins

October 11, 2018 at 4:24 pm #2809100

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you tell me what is happening when you try to activate WPML? If you activate just WPML core, do you get an error? What is the error you are seeing?

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

October 11, 2018 at 6:44 pm #2809546

Arturo

Hei Lauren,
I inserted the lines in wp-config but when I try to visit the site I get error message 500.
I deleted these lines and I am able to access the site. Here I paste a copy of the error message.
Woocommerce Multilingual error message:
"Update Failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions."

WPML error message:
"We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Table 'malecont_tr.mt_icl_strings' doesn't exist
Array
(
[language] => en
[context] => admin_texts_sharing-options
[gettext_context] =>
[domain_name_context_md5] => 19466a63f198a7aa0b7f99e32c6bf70b
[name] => [sharing-options][global]sharing_label
[value] => Share this:
[status] => 0
[translation_priority] => optional
[allow_empty_value] => 1
)"

String Translation error message:
"There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

I also get this error message:
"WPML Translation Management requires the following PHP extensions and settings:

PHP Setting: allow_url_fopen=1"

This one does not show: /wp-content/debug.log

Also, there´s no language showing at all.

October 11, 2018 at 6:47 pm #2809550

Arturo

Additionally, when the WPML plugin is activated then the whole site shows error page 404, not found.

October 11, 2018 at 7:32 pm #2809620

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the additional information. When you access the database, do you see the icl_strings table?

I'd like to install the Adminer plugin so I can take a look at your database. Please let me know if this is okay. Also, neither the WordPress credentials or FTP credentials are allowing me to access your site. Please check the logins and update in the next reply, which I have marked as private. Thanks!

October 11, 2018 at 7:42 pm
October 11, 2018 at 9:01 pm #2809731

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I was able to install the Adminer plugin and remove the string that was causing the error. Now, I have activated the plugins and installed English and Norwegian languages, because that is what I found in your debug information. Adding the languages resolved the 404 homepage error.

Please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:

- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Does this resolve the error message at the top of your dashboard?

October 11, 2018 at 9:08 pm #2809747

Arturo

Thanks a lot!
What about WooCommerce Multilingual? This plugin can not be updated, can you have a look at it, please?

October 11, 2018 at 9:10 pm #2809751

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It's very outdated which is probably why. I recommend deactivating and deleting it. Then, download a clean version from http://www.wpml.org/account/downloads/ and install it from the plugin screen. Let me know if that doesn't work and I can manually install it if needed.

October 11, 2018 at 9:21 pm #2809810

Arturo

That does not work, I guess you can install it manually.

October 12, 2018 at 1:48 pm #2812223

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to install the latest version via FTP. However, I had to rename the old version because when I tried to remove it from FTP, I cot an error that permissions were denied. So you may need to contact your hosting provider to have them adjust the permissions so that you can remove the older version. I simply renamed the folder to rename-woocommerce-multilingual. That's the one that can be removed.

Please let me know if you need any further assistance and I will be happy to help.

October 21, 2018 at 9:21 pm #2836071

Arturo

How do I add permission?