This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bobby 5 months ago.

Assigned support staff: Bobby.

Author Posts
May 3, 2019 at 5:13 pm #3737167

bailgene-s.l.G

I am trying to: use the automatic updates of WooCommerce Multilingual

Link to a page where the issue can be seen: /wp-admin (internal)

I expected to see: updated every day

Instead, I got: not updated.

It works if I update manually, but not when using automatic daily. I use fixer.io service (both for manual and automatic). No errors are shown. I have the latest updates.

May 3, 2019 at 10:49 pm #3738263

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please verify that you have set the frequency to "daily" , i have test this on my local environment and it worked as expected

at the moment what is the current frequency that you are seeing it update ? If you do not update manually does it update automatically ?

May 4, 2019 at 4:48 pm #3740787

bailgene-s.l.G

I would paste images of my interface but this is a forum, not a private channel.

Frequency is daily.

With this frequency, it is not updated. I have started with this "daily" like 8 days ago, and because it was not updated, I pressed update manually 2 or 3 times this week. The maximum time I have waited to be updated automatically is 2 days.

How can see the logs of wmpl multilingual?

My interface is no in English, so, I am going to translate it from top-bottom.

> Many currencies
Enable: Checked
Currencies:

Matrix Currency/Language: Euro, Dollar USD, Dinar BHD

Currency exchange automatic updates: checked
Last updated: a Date
(Button update manually now) => If I press this, it is updated the previous date.

Source/exchange service: fixer.io with key, notice/warning of limitations.
Charge: 0

Update frequency:
Dialy

Options for the selector: Euro, USD, BDH
CSS: Empty

Selector/widget: nothing done here

Selector currency product page: checked

May 6, 2019 at 5:50 pm #3751591

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I was not able to replicate the issue on a clean enviroment if possible i would like to take a closer look at your backend (its ok that the interface is not in English).

If we indeed have to further test this we can migrate to our cloudways enviroment that will allows to perform tests without interfering with your live site

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

May 9, 2019 at 12:12 am #3771665

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i will try to migrate your site to our cloudways servers to further test it for at least one day to see if the update happens on a minimal enviroment to completely rule out any compatibility issues caused by a 3rd party plugin and update you here.

May 9, 2019 at 10:03 pm #3779537

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have recorded so far 2 automatic updates of the foreign exchange on the cloudways server

that happened with only your theme, WPML plugins and Woocommerce + WCML activated which leads me to believe one of your third party applications is blocking the automatic updates

you can find the site here and use your login credentials to access the backend if you wish

latest update was done May 9 11:49pm and this was automatic

May 11, 2019 at 8:30 am #3789923

bailgene-s.l.G

Thank you.

I assume that you tried with all the plugins and it didn't work.

I mean, I don't know if this is related with the plugins (I can search for that, but I will need to change the update time to 1m to check it quickly), or with the hosting/server (out of my control).

May 13, 2019 at 5:54 pm #3801073

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

at the moment i can confirm that WPML and the automatic update for the rates is working as expected within the site with a minimal environment when we test it on our cloudways servers therefore i can confirm that it is not a bug from our side.

If possible please try the following from your side as well and let me know your results

-Back up your site first
-Deactivate all non WPML related plugins
-activate one by one to see with which one there is an interaction issue

The topic ‘[Closed] WooCommerce Multilingual not updated daily’ is closed to new replies.