This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Mihai Apetrei 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 7, 2019 at 2:25 pm #3759237

joaoM-18

I am trying to: Go to page 2 on WooCommerce Multilingual products

I expected to see: Page 2

Instead, I got: An error [ Cannot load wpml-wcml ]

Thanks

May 7, 2019 at 4:59 pm #3760807

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please first create a full backup of the site and then update all the WPML plugins to the latest version?

2. If that did not solve the issue, can you please try this:

- disable all plugins except WPML and its add-ons (leave WooCommerce enabled, too)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

May 7, 2019 at 5:00 pm #3760813

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

3. If the steps above didn't help:

a1. I will need you to please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the content (if any) on a site like pastebin.com and then share the link here with me. Please censor any sensitive information.

a2. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 8, 2019 at 1:59 pm #3767445

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

I can also confirm that the credentials worked.

1. Can you please go here (hidden link), register WPML, then click on "check for updates" and update the WPML plugins to the latest version?

2. After that, can you please go here (hidden link) and update all the plugins to the latest version?

Please let me know if the issue is still persisting after following the steps above.

Kind regards,
Mihai

May 8, 2019 at 2:45 pm #3767891

joaoM-18

Hi Mihai,

WPML is registered in the live website. The staging one is not but he live one is.

I followed the suggestions you made and I still have the problem.

Do you have any more options?

thanks in advance,

May 8, 2019 at 3:49 pm #3768655

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

1. At the moment, on the site the WPML plugins are not updated to the latest version. So I would need you to go to your WPML.org account, generate a new key for the staging site (you can do that under your WPML.org account here - https://wpml.org/account/sites/) and register WPML on the staging site. After that, you should be able to click the "check for updates" button and it will give you the possibility to update the WPML plugins to the latest version.

More about the WPML registration process can be found here:
https://wpml.org/faq/install-wpml/#register

We need to update everything to the latest version so that we can properly run tests using the freshly updated versions. We can't do that using old versions.

2. I still see the other plugin updates waiting to be updated here, too, so after you create a full backup of the site, I will need you to update those, too: hidden link

After we have everything updated to the latest version, the issue might disappear completely or we might get more hints about what is causing this.

Please let me know when that's ready.

Kind regards,
Mihai

May 10, 2019 at 7:36 am #3782005

joaoM-18

Hi Mihai,

I did as you requested: registered the staging website on WPML, checked for updates on WPML and updated the "core" plugins.

The issue is still there, which means I still need help.

Thanks in advance.

May 10, 2019 at 1:32 pm #3785023

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I have disabled all the other plugins and left enabled only the WPML plugins + WooCommerce and now the second page works perfectly (you can take a look on the staging site's backend panel) so this tells us that the issue is created by at least one of the other plugins that were active and that plugin/plugins might not be compatible with WPML.

Please try this:

- reactivate your plugins one by one (you can find a list of the plugins that I disabled in the "Recently active" tab here - hidden link), checking every time if the issue shows up again so that you can understand which plugin is causing that issue

Kind regards,
Mihai

May 13, 2019 at 2:58 pm #3799661

joaoM-18

Hi Mihai,

It's the "Grand Tour Theme Custom Post Type" plugin.
I have all the orther ones activated and everything is working fine.

If you look at the url on top there's a

 &post_type=post 

that shouldn't be there and is breaking the query. If we get that of all works fine.

How can we fix this? The plugin is a must have...

Thanks in advance

May 14, 2019 at 8:20 am #3804643

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am very happy to hear that you were able to find the plugin that was causing the issue.

In this case, my first recommendation would be to contact the plugin authors and recommend them to join our 'Go Global' program (https://wpml.org/documentation/theme-compatibility/go-global-program/) where our Compatibility developers will help them make their plugin 100% compatible with WPML for free.

What I could do on my side though would be to create a clean-install testing site on our servers and if you can replicate the same issue on our servers, too, then that's when I can forward this issue to our compatibility team so that they can take a look at that, too.

Please let me know if you would like me to do this.

I will be waiting for your response.

Kind regards,
Mihai

The topic ‘[Closed] WooCommerce Multilingual > Page 2 click Error: Cannot load wpml-wcml’ is closed to new replies.