This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Raja Mohammed 3 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 25, 2019 at 8:54 am #4082395

bulletM

I am trying to: Add product to the cart

Link to a page where the issue can be seen: Cart page

I expected to see: Added product in cart should remain in cart untill we remove

Instead, I got: After few seconds, it says cart is empty so we cannot place the order. Cart gets empty automatically in very few second. If we disable the plugin woocommerce multilingual which is compulsory with WPML, cart works but then products dose not show in different language. Please help

June 25, 2019 at 11:23 am #4083771

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

Please ensure the cart synchronization is enabled in your WooCommerce multilingual setup, Please go to WooCommerce > WooCommerce Multilingual > Settings > Cart, Enable the option "Synchronize cart content when switching languages". (check the attached screenshot)

In order to cart synchronization to work please make sure the Language cookies are enabled
at WPML > Languages > Language filtering for AJAX operations enable the option
"Store a language cookie to support language filtering for AJAX"

I hope this helps you solve the issue, Please let me know if you need further assistance.

Kind regards
Raja