This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Rohan Sadanandan 1 month ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
September 17, 2019 at 9:52 pm #4591157

jesperS-10

I am trying to: update WooCommerce Multilingual

It says update failed

September 18, 2019 at 1:15 am #4591427

jesperS-10

if i delete the plugin and reinstall it, will existing translations of woocommerce then be lost?

September 18, 2019 at 6:37 am #4592709

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

From the debug information it seems that you are already using the latest version of Woocommerce Multilingual.

For updating the plugins, you can follow the below steps:
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page

If that does not work, try the below step:

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button

If that also does not work, you can manually update the plugins.
❌ Before proceeding please make a full website backup! ❌
- Download the latest version of the plugin from https://wpml.org/account/downloads/
- Disable the plugin
- Delete the plugin (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded plugin from Plugins -> Add New -> Upload Plugin
- Activate the plugin

Also, I request you to update the WP Memory Limit to at least 128MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/
Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan

September 18, 2019 at 8:46 am #4593859

jesperS-10

hi Rohan, thanks. my wp-config.php says /* That's all, stop editing! Happy blogging. */ is this where i should paste it

September 18, 2019 at 9:01 am #4594083

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Yes, you can paste it just before:
/* That's all, stop editing! Happy blogging. */

Thanks,
Rohan